ReSharper 9.2 EAP RC3 - No more 'New Folder' and alt + enter issue

I'm still using ReSharper 8, so maybe this has been the case since version 9 came out, but, thinking of upgrading and wanted to try out RC3. As usual, in the solution explorer, I do the familiar 'alt + enter' only to find 4 choices, Class, Interface, Struct, Enum. What happened to the ability to select 'New Folder'? Why was this removed? I use it all the time. Is there a new way to create a new folder in v9? There is also a 'More' link, but this doesn't give the option of adding in a New Folder link.

Also, alt + enter is not working for me in RC3. I'm using VS 2015 on a Mac using Parallels 10. Then, on a whim, I tried the left 'alt' button, and it worked. For some reason, the right 'alt' button doesn't work. I had this issue both with my Macbook pro keyboard, and an external keyboard that I plugged in. Are there any known issues with ReSharper on a Mac in a Parallels VM? It works just fine in ReSharper 8 in VS 2013.

3 comments
Comment actions Permalink

Hello Alexander,

  I guess you are talking about Alt+Ins shortcut to call Generate menu in Solution Explorer not about Alt+Enter one. So, Alt+Ins menu (Generate) will have "New Folder" inside when you select a project node or a folder node and then hit the shortcut. When you are on a file, ReSharpe will just suggest File Templates list.

  As for left/right Alt - please open Tools | Options | Environment | Keyboard and check if Visual Studio can handle both Alt buttons.

Thanks!

0
Comment actions Permalink

Yes, sorry, I mean alt+insert. And, I figured out the problem thanks to your second comment.

When I go to the Keyboard options in VS, and try out the alt keys, the left alt key returns 'alt', while the right alt key returns 'ctrl+alt' for some reason! Maybe it's because there is no ctrl key on the right side of the built-in keyboard? Strange that it would map the external the same way.

So, when I use the right alt key, the one I'm used to using with ReSharper, nothing works right. I never noticed before I installed Windows on my Mac since I always use the left alt key for Mac shortcuts. So, apparently, ctrl+alt+insert also brings up the menu, but without the 'new folder' option!

Ah! I'll have to find a way to remap the right alt key, I'm too used to hitting alt+enter and alt+insert with one hand.

Thank you!

1
Comment actions Permalink

I am also experiencing this. The folder option is missing in the alt+insert menu. And it doesn't seem to be that easy adding it through the Template Explorer. Any hints on how to get the folder option back?

0

Please sign in to leave a comment.