VS2015 and keyboard shortcuts

I'm used to have ReSharper configured to Visual Studio scheme, but in Visual Studio 2015, I'm struggling to make keyboard binging work.

Installed version of ReSharper is: 9.1.3, Visual Studio: 14.0.23107.0

I could say ReSharper does not work at all for me as I'm heavilly using:

  • Explore (Ctrl+T)
  • Refactor (Ctrl+R+R)
  • Improve (Alt+Enter)
  • Navigate to (Alt+`)


None of these works for me. Tried to reset VS2015 keyboard scheme to default (scheme is called "(Default)"), then did same with ReSharper (chosed VisualStudio scheme), but no result. Did I miss any guide how to set up key scheme different way than I'm used to?

Thanks for any advice :)

11 comments
Comment actions Permalink

Hi guys,

I have the exact same issue here it seems that whatever I check in the Options --> Keyboard & Menus , lets say Visual Studio Scheme - nothing happens...

My resharper Version is

JetBrains ReSharper Ultimate 2015.2 Build 103.0.20150818.200216
dotMemory 4.4.20150819.154207
dotTrace 6.2.20150819.160137
TeamCity Add-in 9.2.20150819.154937
ReSharper 9.2.20150819.164145

Application Packages:
JetBrains DotCommon Core build 103.0.20150818.200932 on 2015-08-18 20:09:32Z.
JetBrains DotCommon ElevationAgent build 103.0.20150818.200932 on 2015-08-18 20:09:32Z.
JetBrains DotCommon ExternalStorage build 103.0.20150818.200932 on 2015-08-18 20:09:32Z.
JetBrains DotCommon Native Core build 103.0.20150818.191814 on 2015-08-18 19:18:14Z.
JetBrains DotCommon.Psi Navigation build 103.0.20150819.153401 on 2015-08-19 15:34:02Z.
JetBrains DotCommon.Psi UnitTesting build 103.0.20150819.153401 on 2015-08-19 15:34:02Z.


and my VS info is

Microsoft Visual Studio Enterprise 2015
Version 14.0.23107.0 D14REL
Microsoft .NET Framework
Version 4.6.00081

Installed Version: Enterprise

any advice would be appreciated

:)

0
Comment actions Permalink

Can you try resetting Visual Studio's keyboard shortcuts (Tools -> Options -> Keyboard + Reset), and then ReSharper -> Options -> Keyboard -> Apply Scheme (the Apply Scheme is the important bit).

Also, can you verify that you are logged into Visual Studio correctly? Log for a warning icon in the top right of Visual Studio. It might be that Visual Studio's settings sync is causing issues.

7
Comment actions Permalink

That did the trick Matt Ellis

thanks a lot :)

0
Comment actions Permalink

Actually something was terribly wrong and I had to repeat this step several times. But I'm actually suspecting myself to do something wrong anyway :) Now it works as expected.

0
Comment actions Permalink

Mine does not contain ReSharper item in ReSharper -> Options -> Keyboard -> Apply Scheme.  Is this a bug?

Thanks a lot.

0
Comment actions Permalink

Have spent far too much time trying to get this working, and it still doesn't work. Frustrated.

 

2
Comment actions Permalink

Hello Matt,

What exactly does not work for you? Does hitting Alt+Enter execute nothing? What action is mapped to Alt+Enter shortcut here Tools | Options | Environment | Keyboard?

Thanks!   

0
Comment actions Permalink

Hi, 

i had the same issue with resharper on VS2015 and spend hours searching, resetting and reinstalling :(

After a couple of resets (meh), as described above i got Crtl+t to work. 

For Alt+Enter i just found the source of the problem (in my case):

In Tools | Options | Environment | Keyboard, alt+enter was assigned globally to "view property", reshaper_altEnter was assingned only for text editor. Probably this confilcted.

You can check if this is the case for you by clicking into "press shortcut key" hitting Alt-Enter and inspecting the dropdown.

Cheers,

Jan 

  

 

0
Comment actions Permalink

How can I get all the default Visual Studio shortcuts, except I want to use these Resharper shortcuts:

 

<Ctrl>-N  - Enter/type symbol file name

<Ctrl>-T, D - Debug unit test

<Alt>-<Enter> - Enter Action

 

I don't see in the Resharper settings where you can configure individual values like this.  It just says "Apply Scheme" so it sets everything to Resharper, or everthing to Visual Studio.  I don't feel like having to re-learn all the keybindings I have been using for years with Visual Studio.

 

0
Comment actions Permalink

Roger, you can get the default shortcuts by going to Tools → Options → Keyboard and hitting the Reset button. This resets all VS shortcuts back to the default, including unassigning all of ReSharper's.

You can now assign any keyboard shortcuts you like to any of ReSharper's actions, in the same Keyboard page in options - just type "ReSharper" in the list and it will filter down to all of the actions ReSharper exports.

Alternatively, you can apply a ReSharper keyboard scheme, and the first time you use a particular keyboard shortcut, ReSharper will prompt you to ask what you want to do - use ReSharper or keep VS. You can apply this per-shortcut, or for all shortcuts. This will allow you to choose one by one.

0
Comment actions Permalink

For me the problem was, that I accidentally changed the keyboard layout form german to english. It took a while until I noticed it. After changing back to german, the ReSharper keyboard shortcuts worked again.

0

Please sign in to leave a comment.