Stylecop for R# 9.2

Hi,

I understand from some users that it is possible to use current version of ReSharper.StyleCop ( (for R#9.1) 4.7.51-beta1) with 9.2 also.
Is it true?
Since I can't see that in Extension Manager, is there a way to manually workaround this?

If not, then I think I'll anyway have to wait until this etension is updated.

Thanks.

5 comments
Comment actions Permalink

No, the 9.1 compatible plugin is compiled against the 9.1 SDK, and won't work with ReSharper 9.2 (the assembly numbers are different, and there are no binding redirects in place). There currently isn't a version of StyleCop for 9.2. You can keep an eye on https://github.com/StyleCop/StyleCop, where I'm planning to build and release a new version, hopefully during this week.

0
Comment actions Permalink

Hi,

      Following the previous reply, is there any progress for the new version of StyleCop for Resharper 9.2 so far? I have tried a few times to pull the plugins for Reshaper, but I still cannot see it.

0
Comment actions Permalink

Hi, yes, I'm working on it right now. You can see the progress at the GitHub site. I'm hoping to get it released by the end of the week (I know I said that before, but I'm actually working on it now :))

0
Comment actions Permalink

Any updates? :-) Anxiously awaiting this release...

0
Comment actions Permalink

Inching closer :)

Here's the list of what's done, and what's still to do: https://github.com/StyleCop/StyleCop/issues/9#issuecomment-138855164

There have been a number of issues with the existing code, including how to get it to work from the gallery, without StyleCop installed, and also fixing the performance throttling to get it a bit smoother.

Soon...

0

Please sign in to leave a comment.