Update background files

Hi

I'm having some major issues with ReSharper constantly displaying "Update background files". I can't really figure out why this happens. I've tried to clean all caches etc., but it doesn't help.
The process takes anywhere from 10 seconds to more than 10 minutes and happens often when renaming files.
My solution contains 57 projects, if that matters.


JetBrains ReSharper 8.0.1 C# Edition
Build 8.0.1000.2286 on 2013-09-05T07:18:00

Licensed to: MailTalk A/S
Plugins: 4
#1. “NuGet support for ReSharper” v1.3.0.28776 by JetBrains
#2. PostfixCompletion v1.0.0.0 by “Shvedov Alexander”
#3. ReSpeller v2.3.0.0 by “Ethereal Code”
#4. “StyleCop (4.7.46.0)” v4.7.1000.0 by http://stylecop.codeplex.com
Visual Studio 11.0.60610.1.


What's going on?

6 comments
Comment actions Permalink

Are no one else experiencing this issue? It's rather
annoying

:(
0
Comment actions Permalink

Did you ever get a resolution to this issue? I am experiencing it now and it is almost unbearable.

JetBrains ReSharper 8.0.2 Full Edition
Build 8.0.2000.2660 on 2013-09-27T14:18:12
Plugins: 1
#1. “NuGet support for ReSharper” v1.3.0.9560 by JetBrains
Visual Studio 12.0.30110.0.
Copyright © 2003–2014 JetBrains s.r.o. All rights reserved

0
Comment actions Permalink

Unfortunately I didn't. My problem disappeared, but I don't know what I did. I'm frequently trying out the EAP's, which might have something to do with it.
One suggestion is to clear all your temporary folders (both system and user directories). This, however, depends on where ReSharper is configured to store the caches (see ReSharper->Options->General->Caches).

If the caches are stored in the "Solution folder", you have to delete the "ReSharperCache" from the solution folder.

If the caches are stored in the "System TEMP folder", you have to find your temporary folder, which can be done from a commandprompt by typing "cd %TEMP%" and "cd %TMP%" or "SET %TEMP%" which displays the location of your temporary folder. This is actually a bit misleading, as ReSharper actually stores the caches in the local user temporary folder.

I'm not sure where to look if caches are stored in the "User local settings folder", but I guess it's somewhere in the "C:\Users\{username}\" directory.


I hope this helps.

0
Comment actions Permalink

You can find the cache files in %LOCALAPPDATA%\JetBrains\ReSharper\vX.X\SolutionCaches, where X.X is the version that you're on - 8.0, 8.1 or 8.2. From the looks of it, you're on 8.0. I'd suggest 8.1 to see if it fixes things, or you can try the 8.2 EAP to see if it's in the latest builds. You can download 8.1 here: http://www.jetbrains.com/resharper/download/ and the 8.2 EAP from here: http://confluence.jetbrains.com/display/ReSharper/ReSharper+8.2+EAP

0
Comment actions Permalink

Appreciate the tips bud. I can only speak to correlation, as I don't know it was the cause, but I did find I had over 1gb of cache files. I deleted those and things are back to normal.

Thanks!

0
Comment actions Permalink

I'm having this exact same issue with the latest version of Resharper Utlimate v9.2 2015.2 on Visual Studio 2010.  I am not sure how to stop this "update background files" progress from constantly happening each time I type something!!  I've tried clearing the cache, etc. as some of the replies here suggest, but this did not resolve it.  Any ideas please?

Thank you

0

Please sign in to leave a comment.