Unable to run R# NUnit tests while attached to IIS Express

When I was using ReSharper 8 I was able to debug web applications via the following approach:

  1. Add breakpoints to code in my web applications
  2. Leave IIS Express running locally, picking up changes to the applications as they are rebuilt
  3. Attach to the IIS Express process in Visual Studio
  4. Run NUnit acceptance tests via the ReSharper test runner to trigger web requests to the web applications, and make assertions about the results


I recently upgraded from ReSharper 8 to ReSharper 9.2 and since doing this step 4 is no longer possible and I don't know why. I run through steps 1, 2, and 3, but when I try to run my acceptance tests as before, I get a Visual Studio "Do you want to stop debugging" prompt and if I say no I then get the following:

Capture.PNG
Visual Studio is still attached to IIS Express after this popup, but I'm not able to run my test. This has broken my workflow as I have a lot of tests that trigger different functionality, and I want to be able to attach to IIS Express while I run them.

I've tried this in both Visual Studio 2013 and 2015, and both have the same behaviour now. I didn't intend to upgrade R# in VS 2013 but installed via Chocolatey and wasn't given the option.

If anyone could give me any tips on replicating my old workflow I would be very happy. I've got quite a lot of work to do at the moment and this issue has really slowed me down.

1 comment
Comment actions Permalink

Me too!

No solution yet, but I am facing the same issue.

0

Please sign in to leave a comment.