VS 2015 ReSharper 9.2 bulb is bugged

I have the option "Do not show Visual Studio bulb (...)" checked under Visual Studio integration and yet not only it's shown but it's seems to be bugged.

I'm trying to delete some unused namespaces.

When I'm trying to click on "Remove unused directives in file" it throws the following error "Cannot perform this action, most likely because of errors in the source code" where I have none! the projects compiles just fine.

The project is a new ASP.NET v5 empty project.

6 comments
Comment actions Permalink

I'm experiencing the same type of behavior after creating a new empty class library project. None of the code analysis seems to run and R# doesn't recognize used variables/fields and won't allow any refactorings. If I open up the project using VS2013, everything seems to work OK.

0
Comment actions Permalink

Hello Eyal,

  Could you please attach here such sample project and also specify Help | About MS Visual Studio | Copy Info? Since I was not able to reproduce the mentioned behavior on my side.

Thanks!

0
Comment actions Permalink

I just uploaded example from VS 2015 (with Resharper functionality; but don't know where I can track it)

Let me also update example here with screenshots

Env: VS 2015 Enterprise
Resharper 10.0.1
Windows 8.1



Attachment(s):
ResharperBug.zip
0
Comment actions Permalink

Which ReSharper Extensions do you have installed?

I had an issue with 9.2 and VS 2015 with the Agent Mulder extension; it caused many methods, fields, arguments and variables to be marked as unused: https://youtrack.jetbrains.com/issue/RSRP-448034

0
Comment actions Permalink

only stylecop extension

interesting..  probably I should spend some time later, turning every vs and resharper extensions off

0
Comment actions Permalink

Yep, it was Style Cop extension... gonna write to them

Upd: answered by Alexander, I had to use different extension:

http://resharper-support.jetbrains.com/hc/en-us/articles/213833588--Cleanup-Code-menu-item-is-disabled-and-Cleanup-Code-option-page-is-empty

0

Please sign in to leave a comment.