Can't install SDK via package manager in VS2015 RTM

When trying to install the JetBrains.ReSharper.SDK package via nuget package manager in VS2015 I always get the following error:

Could not install package 'JetBrains.ExternalAnnotations 9.1.0.9'. You are trying to install this package into a project that targets '.NETFramework,Version=v4.0', but the package does not contain any assembly references or content files that are compatible with that framework. For more information, contact the package author.

I have tried every target framework from 4.0 to 4.6 and I get the same error with every one. I also created a fresh project and am still getting the error.

Here is a full log from the package manager:


Attempting to gather dependencies information for package 'JetBrains.ReSharper.SDK.9.1.20150522.81235' with respect to project 'ClassLibrary1', targeting '.NETFramework,Version=v4.0'
Attempting to resolve dependencies for package 'JetBrains.ReSharper.SDK.9.1.20150522.81235' with DependencyBehavior 'Highest'
Resolving actions to install package 'JetBrains.ReSharper.SDK.9.1.20150522.81235'
Resolved actions to install package 'JetBrains.ReSharper.SDK.9.1.20150522.81235'
For adding package 'Antlr2.Runtime.2.7.7.2' to project 'ClassLibrary1' that targets 'net4'.
For adding package 'Antlr2.Runtime.2.7.7.2' to project 'ClassLibrary1' that targets 'net4'.
Adding package 'Antlr2.Runtime.2.7.7.2' to folder 'C:\gitrepos\testproj\ClassLibrary1\packages'
Added package 'Antlr2.Runtime.2.7.7.2' to folder 'C:\gitrepos\testproj\ClassLibrary1\packages'
Added reference 'antlr.runtime' to project 'ClassLibrary1'.
Added package 'Antlr2.Runtime.2.7.7.2' to 'packages.config'
Added file 'packages.config' to project 'ClassLibrary1'.
Successfully installed 'Antlr2.Runtime 2.7.7.02' to ClassLibrary1
For adding package 'Antlr2.Tools.2.7.6.3' to project 'ClassLibrary1' that targets 'net4'.
For adding package 'Antlr2.Tools.2.7.6.3' to project 'ClassLibrary1' that targets 'net4'.
Adding package 'Antlr2.Tools.2.7.6.3' to folder 'C:\gitrepos\testproj\ClassLibrary1\packages'
Added package 'Antlr2.Tools.2.7.6.3' to folder 'C:\gitrepos\testproj\ClassLibrary1\packages'
Added package 'Antlr2.Tools.2.7.6.3' to 'packages.config'
Successfully installed 'Antlr2.Tools 2.7.6.3' to ClassLibrary1
For adding package 'DotNetZip.Reduced.1.9.1.8' to project 'ClassLibrary1' that targets 'net4'.
For adding package 'DotNetZip.Reduced.1.9.1.8' to project 'ClassLibrary1' that targets 'net4'.
Adding package 'DotNetZip.Reduced.1.9.1.8' to folder 'C:\gitrepos\testproj\ClassLibrary1\packages'
Added package 'DotNetZip.Reduced.1.9.1.8' to folder 'C:\gitrepos\testproj\ClassLibrary1\packages'
Added reference 'Ionic.Zip.Reduced' to project 'ClassLibrary1'.
Added package 'DotNetZip.Reduced.1.9.1.8' to 'packages.config'
Successfully installed 'DotNetZip.Reduced 1.9.1.8' to ClassLibrary1
For adding package 'JetBrains.Annotations.9.1.1' to project 'ClassLibrary1' that targets 'net4'.
For adding package 'JetBrains.Annotations.9.1.1' to project 'ClassLibrary1' that targets 'net4'.
Adding package 'JetBrains.Annotations.9.1.1' to folder 'C:\gitrepos\testproj\ClassLibrary1\packages'
Added package 'JetBrains.Annotations.9.1.1' to folder 'C:\gitrepos\testproj\ClassLibrary1\packages'
Added reference 'JetBrains.Annotations' to project 'ClassLibrary1'.
Added package 'JetBrains.Annotations.9.1.1' to 'packages.config'
Successfully installed 'JetBrains.Annotations 9.1.1' to ClassLibrary1
For adding package 'JetBrains.Build.Platform.Tasks.ThemedIconsPacker.2.0.20141124' to project 'ClassLibrary1' that targets 'net4'.
For adding package 'JetBrains.Build.Platform.Tasks.ThemedIconsPacker.2.0.20141124' to project 'ClassLibrary1' that targets 'net4'.
Adding package 'JetBrains.Build.Platform.Tasks.ThemedIconsPacker.2.0.20141124' to folder 'C:\gitrepos\testproj\ClassLibrary1\packages'
Added package 'JetBrains.Build.Platform.Tasks.ThemedIconsPacker.2.0.20141124' to folder 'C:\gitrepos\testproj\ClassLibrary1\packages'
Added package 'JetBrains.Build.Platform.Tasks.ThemedIconsPacker.2.0.20141124' to 'packages.config'
Successfully installed 'JetBrains.Build.Platform.Tasks.ThemedIconsPacker 2.0.20141124.0' to ClassLibrary1
For adding package 'JetBrains.ExternalAnnotations.9.1.0.9' to project 'ClassLibrary1' that targets 'net4'.
Install failed. Rolling back...
Package 'JetBrains.ExternalAnnotations 9.1.0.9' does not exist in project 'ClassLibrary1'
Removed package 'JetBrains.Build.Platform.Tasks.ThemedIconsPacker 2.0.20141124.0' from 'packages.config'
Removed package 'JetBrains.Annotations 9.1.1' from 'packages.config'
Removed reference 'JetBrains.Annotations.dll' from project 'ClassLibrary1'
Removed package 'DotNetZip.Reduced 1.9.1.8' from 'packages.config'
Removed reference 'Ionic.Zip.Reduced.dll' from project 'ClassLibrary1'
Removed package 'Antlr2.Tools 2.7.6.3' from 'packages.config'
Removed file 'packages.config' from folder 'C:\gitrepos\testproj\ClassLibrary1\ClassLibrary1'.
Removed package 'Antlr2.Runtime 2.7.7.02' from 'packages.config'
Removed file 'packages.config'
Removed reference 'antlr.runtime.dll' from project 'ClassLibrary1'
Package 'JetBrains.ExternalAnnotations 9.1.0.9' does not exist in folder 'C:\gitrepos\testproj\ClassLibrary1\packages'
Removing package 'JetBrains.Build.Platform.Tasks.ThemedIconsPacker 2.0.20141124.0' from folder 'C:\gitrepos\testproj\ClassLibrary1\packages'
Removed folder 'C:\gitrepos\testproj\ClassLibrary1\packages\JetBrains.Build.Platform.Tasks.ThemedIconsPacker.2.0.20141124.0\build'.
Removed file 'JetBrains.Build.Platform.Tasks.ThemedIconsPacker.2.0.20141124.0.nupkg' from folder 'C:\gitrepos\testproj\ClassLibrary1\packages\JetBrains.Build.Platform.Tasks.ThemedIconsPacker.2.0.20141124.0'.
Removed folder 'C:\gitrepos\testproj\ClassLibrary1\packages\JetBrains.Build.Platform.Tasks.ThemedIconsPacker.2.0.20141124.0'.
Removed package 'JetBrains.Build.Platform.Tasks.ThemedIconsPacker 2.0.20141124.0' from folder 'C:\gitrepos\testproj\ClassLibrary1\packages'
Removing package 'JetBrains.Annotations 9.1.1' from folder 'C:\gitrepos\testproj\ClassLibrary1\packages'
Removed folder 'C:\gitrepos\testproj\ClassLibrary1\packages\JetBrains.Annotations.9.1.1\lib\portable-net4+sl5+netcore45+wpa81+wp8+MonoAndroid1+MonoTouch1'.
Removed folder 'C:\gitrepos\testproj\ClassLibrary1\packages\JetBrains.Annotations.9.1.1\lib\portable-net4+sl4+wp7+netcore45'.
Removed folder 'C:\gitrepos\testproj\ClassLibrary1\packages\JetBrains.Annotations.9.1.1\lib\net20'.
Removed folder 'C:\gitrepos\testproj\ClassLibrary1\packages\JetBrains.Annotations.9.1.1\lib'.
Removed file 'JetBrains.Annotations.9.1.1.nupkg' from folder 'C:\gitrepos\testproj\ClassLibrary1\packages\JetBrains.Annotations.9.1.1'.
Removed folder 'C:\gitrepos\testproj\ClassLibrary1\packages\JetBrains.Annotations.9.1.1'.
Removed package 'JetBrains.Annotations 9.1.1' from folder 'C:\gitrepos\testproj\ClassLibrary1\packages'
Removing package 'DotNetZip.Reduced 1.9.1.8' from folder 'C:\gitrepos\testproj\ClassLibrary1\packages'
Removed folder 'C:\gitrepos\testproj\ClassLibrary1\packages\DotNetZip.Reduced.1.9.1.8\lib\net20'.
Removed folder 'C:\gitrepos\testproj\ClassLibrary1\packages\DotNetZip.Reduced.1.9.1.8\lib'.
Removed file 'DotNetZip.Reduced.1.9.1.8.nupkg' from folder 'C:\gitrepos\testproj\ClassLibrary1\packages\DotNetZip.Reduced.1.9.1.8'.
Removed folder 'C:\gitrepos\testproj\ClassLibrary1\packages\DotNetZip.Reduced.1.9.1.8'.
Removed package 'DotNetZip.Reduced 1.9.1.8' from folder 'C:\gitrepos\testproj\ClassLibrary1\packages'
Removing package 'Antlr2.Tools 2.7.6.3' from folder 'C:\gitrepos\testproj\ClassLibrary1\packages'
Removed folder 'C:\gitrepos\testproj\ClassLibrary1\packages\Antlr2.Tools.2.7.6.3\build'.
Removed folder 'C:\gitrepos\testproj\ClassLibrary1\packages\Antlr2.Tools.2.7.6.3\tools'.
Removed file 'Antlr2.Tools.2.7.6.3.nupkg' from folder 'C:\gitrepos\testproj\ClassLibrary1\packages\Antlr2.Tools.2.7.6.3'.
Removed folder 'C:\gitrepos\testproj\ClassLibrary1\packages\Antlr2.Tools.2.7.6.3'.
Removed package 'Antlr2.Tools 2.7.6.3' from folder 'C:\gitrepos\testproj\ClassLibrary1\packages'
Removing package 'Antlr2.Runtime 2.7.7.02' from folder 'C:\gitrepos\testproj\ClassLibrary1\packages'
Removed folder 'C:\gitrepos\testproj\ClassLibrary1\packages\Antlr2.Runtime.2.7.7.02\lib'.
Removed file 'Antlr2.Runtime.2.7.7.02.nupkg' from folder 'C:\gitrepos\testproj\ClassLibrary1\packages\Antlr2.Runtime.2.7.7.02'.
Removed folder 'C:\gitrepos\testproj\ClassLibrary1\packages\Antlr2.Runtime.2.7.7.02'.
Removed folder 'C:\gitrepos\testproj\ClassLibrary1\packages'.
Removed package 'Antlr2.Runtime 2.7.7.02' from folder 'C:\gitrepos\testproj\ClassLibrary1\packages'
Could not install package 'JetBrains.ExternalAnnotations 9.1.0.9'. You are trying to install this package into a project that targets '.NETFramework,Version=v4.0', but the package does not contain any assembly references or content files that are compatible with that framework. For more information, contact the package author.
========== Finished ==========

1 comment
Comment actions Permalink

This appears to be an issue with the new nuget client in VS2015. The SDK installs correctly in VS2013, but something's changed in the new version that breaks the JetBrains.ExternalAnnotations package. We've reported the issue to the NuGet team. The current workaround, unfortunately, is to use Visual Studio 2013 to add the references. Once added, the project and solution open fine in VS2015.

0

Please sign in to leave a comment.