ctrl+click and MVC views

Answered

I used to be able to ctrl+click on the name of a view and it would take me to that view. For example, in the following code I would be able to ctrl+click on SearchRegistrations and it would take me to that .cshtml page. I'm not sure if this was a VS thing or a ReSharper thing, but I seemed to have lost it. Any ideas?

[HttpGet]
public ViewResult Search()
{
     return View("SearchRegistrations");
}

(Let me add, that this feature is still working in VS 2012 with RS 2016.2.2)

 

Running ReSharper 2016.2.2

VS 2015 Update 3

8 comments
Comment actions Permalink

Hi Steven!

Yes, it's ReSharper's feature.

Are you working on the same project in both Visual Studios?

Which MVC version used in project?

If you are using ASP.NET Core 1.0 pre-release bits in VS2015 - ReSharper dropped it's support in 2016.2.

Only ASP.NET Core 1.0 RTM (and, previous release versions too, of course).

0
Comment actions Permalink

I'm not working on the same project in both Visual Studios, I have two different projects.

I'm using ASP.NET Core MVC (sometimes called MVC 6).

I'm running .NET Core 1.01. I even tried re-installing it, but it didn't help.

P.S. I ran a repair of ReSharper but it didn't work.

0
Comment actions Permalink

What version Microsoft.AspNetCore.* packages in project.json?

0
Comment actions Permalink

Here it is:

"dependencies": {
"Microsoft.AspNetCore.Diagnostics": "1.0.0",
"Microsoft.AspNetCore.Mvc": "1.0.1",
"Microsoft.AspNetCore.Mvc.TagHelpers": "1.0.1",
"Microsoft.AspNetCore.Server.IISIntegration": "1.0.0",
"Microsoft.AspNetCore.Server.Kestrel": "1.0.1",
"Microsoft.AspNetCore.StaticFiles": "1.0.0",
"Microsoft.Extensions.Logging.Console": "1.0.0",
"Microsoft.VisualStudio.Web.BrowserLink.Loader": "14.0.0"
},

"tools": {
"Microsoft.AspNetCore.Server.IISIntegration.Tools": "1.0.0-preview2-final"
},

0
Comment actions Permalink

For what it's worth, I deleted all my ReSharper cache from disk based on the locations here: http://stackoverflow.com/a/17806179/366763

Still no luck.

This problem began after I upgraded to the latest version last week.

0
Comment actions Permalink

I just discovered that it's working in another VS 2015 project, but not this other project (it's project.json packages are listed above).

So that means there's something about this particular project that broke the 2016.2.2 version of ReSharper, because it was working in the previous version.

0
Comment actions Permalink

Yeah, it' definitely something project specific.

If you could create ticket in tracking system https://youtrack.jetbrains.com/issues/RSRP and attach the project (or recreating a small project showing the problem) that would be helpful.

0

Please sign in to leave a comment.