Autocomplete on Enter

Hi All,

I have the Problem that I can't seem to be able to insert the highlighted Autocomplete option with the enter key. The Enter key only seems to work after i have hard selected an item with the arrow keys.

This Behaviour drives me crazy since im used to using the enter key for autocomplete. I dug through the Options, but could not find a way to change this behaviour.

 

The Docs state:

 

To choose the pre-selection mode, configure it for each language and context on the Environment | IntelliSense | Autopopup page of ReSharper options : choose Display and preselect for hard selection or Display but do not preselect for soft selection.

 

When the completion popup is invoked explicitly, for example with CtrlSpace, the best match always has a hard selection.

I have selected Display and Preselect for everytying:

But I still cant use the Enter key (I dont get hard selection), even after i have opened autocomplete manually with cntrl + space.

 

 

Am I missing something?

0
3 comments

Hello JRDesign, thank you for your question. What Intellisense option do you have set in the (Extensions) | ReSharper | Options | Environment | IntelliSense | General? Could you please attach a screenshot illustrating the issue with code completion? Thank you!

 

0

Yes I have the same Issue why do you make it so hard to make this simple change?

0

Hello Thomasponzo6, thank you for your question. I have checked this behavior and could not reproduce it using ReSharper code completion in C# files. Could you please respond to the following questions?

What Intellisense option do you have set in the (Extensions) | ReSharper | Options | Environment | IntelliSense | General? Could you please attach a screenshot illustrating the issue with code completion? 

Also, please check what settings you have here: (Extensions) | ReSharper | Options | Environment | IntelliSense | Autopopup. If this happen in C# code, then you can select the C# tab and check whether the values are set to Display and preselect everywhere. Thank you!

0

Please sign in to leave a comment.