How do I stop Resharper C++ formatting if statements like this?

I cannot seem to figure out how to stop Resharper putting if statements on the same line as the opening bracket of a function. I've tried resetting my Resharper config to default and even tried using a completely stock .clang-format but it still happens. It doesn't happen on a secondary PC I have, also running Resharper so I don't kno wwhat's going on here. 
I had a look at the bracket/wrapping options in the config but I couldn't figure out which one affects this behaviour. 

Any help would be much appreciated. 



Could you please verify that it's R# changing the formatting by suspending R# using “Tools | Options | ReSharper | General | Suspend Now” and check whether this fixes the issue?

Could you share your R# settings and/or .editorconfig if you have one in your project?



Ah, suspending R# shows that the issue still occurs, so I guess this is a stock Visual Studio formitting problem. Thanks


Maybe you have clang-format enabled in VS options?


Please sign in to leave a comment.