Prevent auto private modifier to class fields

If I am creating a member field like int my_field , when I press semi-colon to end the line, Resharper adds a private modifier to the beginning and inserts a new line. How can I prevent this behavior?

 

Do not change "int my_field;" to "private int my_field;"

2 comments
Official comment

Hello!

 

Thank you for contacting us.

By default R# uses code style that suggests to use private modifier explicitly,  this behavior can be configured in ReSharper | Options | Code Editing | C# | Code Style | Modifiers | Use explicit/implicit modifier for type members.

Here's more detailed information on this matter - https://www.jetbrains.com/help/resharper/Modifiers_Style.html.

Thank you.

Please sign in to leave a comment.