Intellense autocomplete inserting Tab instead of Space

Since the latest update when using intellisense in Visual Studio 2017 a tab is inserted at the end instead of a space.
Is it possible to change this behaviour within the options somewhere?

It looks very strange when my code looks like:

Constructor(IParam    name, OtherParam    otherName)

I have switched off resharper intellisense for now... But would like to get it back someday :)



Hello Pierre!


Thank you for contacting us.

Could you please export and provide R# settings files from all layers.

You can use any file sharing service or upload them using 'Submit a request' form on the top of this page.

Thank you.


I'm encountering it too, I've never seen it before. Any chance an extension (in R# or VS) is causing this?


edit: I uninstalled my R# extensions (about 18 of them) and the problem went away. Reinstalled my 7 favorite ones and the problem is still fixed. Not sure which of the other 11 was misbehaving...


Hello Pocky!


Thank you for the feedback.

In case the problem appears and you could detect which extension causes this problem please share with us, so we could let know other users as well.

Thank you.


Please sign in to leave a comment.