Tab seems completely broken

I had a previous issue where Tab was triggering insert via TAB.

 

This was resolved after clearing the cache, but it's started happening again. Except it's even worse now.

e.g. I type

BitConverter,

and then select TOSTring(), hit tab and I get.

Yes, that's BitConverter._ ()

I've tried uninstalling and reinstalling, that didn't fix it. I've tried clearing caches, that hasn't fixed it.

I'm also seeing auto complete put tabs in after everything. So I end up with code like this:

I've had to turn resharper off as it's made Visual Studio (2017 Enterprise, latest version) completely unusable.

2 comments

Hello Stuart!

 

Sorry to know you've experienced inconvenience with R#.

Could you please give R# one more try, install it and check if issue is reproduced in newly created solution or in some specific only?

Thank you.

0

Have you tried to reset all Visual Studio settings. I remember seeing this once before and if I am not mistaken this might be a setting in Visual Studio. Menu Tools => Import & Export settings => Reset all settings and you can save your currenty settings so that you can import them back.

Another way is to start Visual Studio with the command-line devenv.exe and the argument /ResetSettingsFull.

0

Please sign in to leave a comment.