Intellisense for netcoreapp2.0 referencing netframework4.6.1 library

Completed

I installed visual studio 15.3 and the .net core 2.0 sdk today.  I created a console application(netcoreapp2.0) with a project reference to a library(netframework4.6.1).  With ReSharper enabled I'm not getting any intellisense for types in the library, I even get : "Cannot Resolve Symbol"  If I suspend ReSharper, intellisense starts working. I even Installed the latest ReSharper 2017.2 EAP build and it didn't fix it.

 

Is there a workaround for this?

7 comments

Hello Charles!

 

Thank you for the feedback.

Unfortunately cannot reproduce the problem on VS 15.3 + ReSharper 2017.2 EAP 12.

Could you please provide your solution in which the error is reproduced and a screenshot illustrating the problem.

Thanks in advance!

0

Hello Charles!

 

Thank you for the reply.

Could you please start VS with the following command: "devenv /ReSharper.LogFile C:\log\resharper_log.txt /ReSharper.LogLevel Verbose", open problem solution and send us log file.

You can do it privately using 'Submit a request' form.

Thank you.

0

Hello,

I updated Resharper with ReSharper 2017.2 EAP 13 and the problem was solved.

 

Thank you very much

0

Great! Thank you for letting us know. :)

0

Is there going to be a solution that does not involve installing the EAP? Either an update to 2017.1 or releasing 2017.2.

0

Hello Patrick!

 

Upcoming ReSharper 2017.2 release will include fix for this issue.

Thank you.

0

Please sign in to leave a comment.