Keyboard shortcuts

In earlier versions of Resharper C++ (earlier than 2017.1) there was a useful facility that when you used a shortcut for the first time, you were prompted to select either the VS or Resharper version.

Is there such a facility in the current version and if so, how do I activate it?

I seem to have to choose either entirely VC or entirely Resharper options and cannot find the individual Resharper options in Tools > Options >Environment > Keyboard, so I cannot even select them manually.

I am using VS2017 Community 15.2 and RS2017.1.

Thanks

9 comments

Hello,

The keyboard shortcuts scheme can be selected on the ReSharper | Options | Environment | Keyboard & Menus page.

Thanks!

0

So that is a "no", is it?

It is all or nothing in the new version.

The old prompting approach was much better.

0

The behavior is still the same. Please try resetting Visual Studio keyboard settings (the "Reset" button in Tools | Options | Environment | Keyboard), then re-apply the ReSharper keyboard shortcut scheme from Resharper | Options | Keyboard & Menus. After that the dialog should be shown for conflicting shortcuts again.

All ReSharper commands start with "ReSharper" and should be shown in the command list on the Keyboard option page. Which command specifically were you not able to find?

0

Thanks Igor,

Yes, you are correct, I just needed to wait.

There is a delay of a minute or two for the first shortcut, I must have shut VS down before I saw it.

0

It only seems to work for selected shortcuts.

For instance, I can't get Alt + F12 to offer the VS Peek Definition.

Also some of the delays before the pop-up are ridiculous.

0

Could you please clarify when this delay happens? After you press a shortcut and until the dialog is shown? The dialog should really appear instantly. Is Visual Studio responsive during this delay?

I can't reproduce the Alt+F12 problem either. Could you please check again that after you reset the shortcuts the dialog does not get shown after Alt+F12? Is the "Apply to all ReSharper Ultimate shortcuts" checkbox not selected in the dialog?

0

Yes, the delay is between pressing the first shortcut and the appearance of the dialog. The second shortcut comes up immediately. VS is responsive during the delay. Alt+F12 puts up a tooltip "No errors found in solution", so it looks like it is performing a next error in solution command.

If I reset the keyboard in VS options to Default or ViC++6 and change to Visual Studio keyboard scheme in Resharper options, then Alt+F12 works as Peek Definition. However, then I have no Resharper shortcuts.

If I then change in Resharper options to Resharper scheme, it thinks for a couple of minutes before VS responds. After that some commands bring up a dialog and some do not and it is not always the same ones (I have reset many times). For instance on the latest attempt, as well as Alt+F12, Alt+up arrow does not bring up the dialog, but Alt+down arrow does.

 

0

Hello Roger

Please try executing the following steps:

  • Close all Visual Studio instances;
  • Open "%LocalAppData%\JetBrains\ReSharper\vAny\vs15.0_{SomeID}" folder;
  • Delete "vsActionManager.DotSettings" file;
  • Open Visual Studio;
  • Select shortcut scheme when prompted;

Then try hitting mentioned shortcuts one again.

Thanks!  

 

0

Hi Alexander,

That seems to set the Resharper keyboard scheme to None.

Resharper shortcuts like Rename work, but none of the VS shortcuts I tried do anything, but I wasn't prompted for anything.

Am I supposed to change the scheme manually first?

I tried selecting the VS scheme in Resharper options, but VS shortcuts still don't work and there are no prompts.

Only resetting the scheme in VS Options activates VS shortcuts.

0

Please sign in to leave a comment.