Resharper navigation, code generation and Intellisense not working for my UWP application


So I'm facing a weird problem lately with ReSharper. As the title indicates, the navigation, the code generation, and the Intellisense are not working for my UWP application. I'm using Visual Studio 15 version 14.0.25431.1, ReSharper Ultimate 2017.1.3, and what is weird for me is that highlighting and colors work, and also all the features work on other C++ projects.

I tried some solutions I found on the net like deleting the .suo file from the .vs folder, clearing the cache for ReSharper, but nothing worked.

Any help would be appreciated, and thank you.



ReSharper C++ does not yet understand C++/CX, so most of the features are disabled on UWP projects.


That was my guess too, so I wanted to make sure. So there is no way around it? @Igor Akhmetov

And thank you for the quick response.


Sorry, probably no way at the moment.

If it's an option, you could try using, which is a standard C++ wrapper for the Windows Runtime, instead of using C++/CX.


I'll check that. Thank you for the help.


Please sign in to leave a comment.