35 comments
Comment actions Permalink

Great!

You can share it privately via 'Submit a request' form which is in the top of the page.

Thank you.

0
Comment actions Permalink

Oddly, it was working yesterday.

While troubleshooting the problem, I tried many thing. One thing was create a fresh project to see if it was broken. It was not, but I saw that the default .NET Framework was 4.6.2, so I then I had branched my code and worked on updating my solution from .NET Framework 4.0 to 4.6.2. Doing so fixed my problems in my branch, so I came back to my original branch (still using .NET Framework 4.0) and all the errors were gone!!! I don't know what fixed it, but it was working all day. It was almost like some cache got updated or reset or something (not sure).

However, this morning I open my project again and the errors are back. :( This weekend, I'm going to update my .NET Framework for all projects in the solution from .NET 4.0 to 4.5 and see if my problems go away. If they do not, I will then send you my project.

Thanks again!

Luc

0
Comment actions Permalink

Thank you for the reply, Lucas.

Anyway looking forward for any news from you.

0
Comment actions Permalink

I have similar issue in Rider on Windows. I was able to reproduce it.

Environment: Windows 10, Rider 2017.3.1

Project: Default .NET ASP.NET Web Application without any modifications

Problem: After upgrading Microsoft.AspNet.Mvc from 5.2.3 to 5.2.4 and Microsoft.AspNet.WebPages from 3.2.3 to 3.2.4 Rider does not recognize application as MVC and stops showing specific contextual menus for creating view/partal views, stops navigating from Controllers to related views, etc.

Example project: 

master branch works ok:

https://bitbucket.org/tsvayer/rider.aspnetmvc.problem/src/bb36a70e0f598c7f2c632150954a8317eace9356/?at=master

problem branch is problematic one with upgraded Asp.Net dependencies:

https://bitbucket.org/tsvayer/rider.aspnetmvc.problem/src/c388919195e6ff67277d3e0e443e7813f7c6adac/?at=problem

0
Comment actions Permalink

This happened to me too with Resharper last week with an MVC 5.2.3 project and static analysis views. I switched to rider because it's static analysis was working for the most part except for an isolated unrelated and esoteric thing I have a bug report for.

But I still tried to get VS with Resharper to work again by invalidate caches, reinstall resharper/visual studio, nothing worked. I update to MVC 5.2.4 and rider static analysis broke, I reverted to MVC 5.2.3 and rider works again, resharper still doesn't. 

This all seems to have happened when the http://resharper-plugins.jetbrains.com/packages/JetBrains.ExternalAnnotations/10.2.42 and 10.2.41 came out. I don't see a way to revert them to test, but I suspect a bad update the timing makes sense and the fact that I can't get this project with no changes that has worked for years to acknowledge views in resharpers static analysis.

0

Please sign in to leave a comment.