ReSharper stopped working (at all, even though the green check is shown below) after update to 2017.1.1

Hello, 

 

After updating to 2017.1.1, ReSharper stopped working. It starts when VS is started, shows "Loading...", then the green check at the bottom is shown (no errors detected), but it does not work at all. There's no 'ctrl+click', no 'Find usages', absolutely nothing in the context (right click) menu, related to ReSharper. 

"Reanalyze all" option does absolutely nothing. Turning the solution-wide analysis on and off does not help either.

Using Visual Studio 2017 (26403.0), CMake project.

 

It's interesting, that this used to happen with previous versions too, but after (a single, rarely two-three) VS restart(s), it used to start working. Now restarts do not help.

 

Any magical command to dump some logs to see what happens?

 

Thanks in advance, 

Kiril

 

EDIT: After a few more restarts, I saw "Updating source files" after "Loading..." and then it started working normally again. So, this may not be related to the update after all.

Anyway, if there's any way to catch some logs (or something useful), when this happens again, will probably be a good thing. 

6 comments

Hello,

I suspect another problem in integration with VS's CMake support. Could you please use the following log config:

<?xml version="1.0" encoding="UTF-8" ?>
<configuration>
<appender name="file" class="JetBrains.Util.Logging.FileLogEventListener" pattern="%d{HH:mm:ss.fff} |%l| %-30c{1}| %M%n">
<arg>c:\tmp\resharper-{date}.log</arg>
</appender>
<logger name="JetBrains.Platform.VisualStudio.SinceVs15.ProjectModel.OpenFolderFileContextTracker" level="TRACE">
<appender-ref>file</appender-ref>
</logger>
<logger name="JetBrains.Platform.VisualStudio.SinceVs15.ProjectModel.VsWorkspaceListener" level="TRACE">
<appender-ref>file</appender-ref>
</logger>
</configuration>

You can probably leave the logging on, and if you notice another problem after a VS restart just send us the logs.

Please note that solution-wide analysis does not work for C++, so you can just disable it in a purely C++ solution.

Thanks!

 

0

Once I have added this logging config, should I still run the VS with /ReSharper.internal in order to generate the desired logs?

 

Where should I attach the log files?

 

OK, I'll disable the solution-wide analysis. Thanks for the information. Once I reproduce the situation, I'll send you the log files.

0

Actually, after updating to 26403.0 looks like I can reproduce the problem, let me see what we can do. FWIW, reopening the solution in the same VS instance seems to help.

0

Hello,

I believe I've fixed that problem. I've prepared a build will all the latest changes (with both CMake issues that you've reported fixed) which is very close to what will be published as 2017.1.2 - https://yadi.sk/d/0Fhnnt6-3GsTtT. If you have a chance, please try it and let us know how R++ works with your project now.

Thanks a lot for your help!

0

Hi Igor, 

 

It looks like it's working fine for now. I'll write again, if I face some (of these) issues.

 

Thanks!

Kiril

0

Thanks a lot for trying it out! I believe the final 2017.1.2 build will be out in a couple of weeks.

0

Please sign in to leave a comment.