Unreal Engine macros and parent classes

The last post I found on this topic was created over a year ago and so I wanted to check if there's any progress/workaround on the matter. When using Reshaper C++ it still doesn't recognize unreal macros (UCLASS,GENERATED_BODY, etc.) and marks them as errors.
Not sure if it's the reason for the next thing: for my class inheriting from AActor it detects it as if it's based on UObject and so much of the parent functions calls are marked as errors.

2 comments

Hello,

What kind of errors does R++ show on these macros and what last version of R++ did you try?

If I recall correctly, definitions of these macros are generated during the build process, so you should at least successfully build your project. They also use __LINE__ in the expansion. I believe we've fixed an issue (https://youtrack.jetbrains.com/issue/RSCPP-17854) in 2016.3 when after typing in a file with these macros their expansion could break. But even with this fixed, if you type in a file and macros move to a different line, the code will be red until a rebuild which will update macro definitions with correct lines.

Thanks!

0

Rebuilding fixed it, didn't think to do it, thanks a lot!

0

Please sign in to leave a comment.