Unable to install dotTrace

Answered

Installing the Resharper Ultimate suite fails when it gets to dotTrace.

It's reporting that it can't find the package "EtwService.msi".

 

 

This dialogue box is followed by this:

 

7 comments
Comment actions Permalink
Official comment

Hi David,

It looks like cached .msi file for our ETW Collector service was removed from Windows cache. Please download this tool from Microsoft: https://support.microsoft.com/en-us/help/17588/fix-problems-that-block-programs-from-being-installed-or-removed , run it, Select "Installing"/JetBrains ETW Host Service/"Yes, try uninstall".

Then you need to reinstall dotTrace or you can just open %localappdata%\JetBrains\Installations\dotTrace07\Msi.x64 folder, right-click on EtwService.msi file and select "Install" option.

Comment actions Permalink

I've tried using the desktop and the web installers.

1
Comment actions Permalink

That worked.  Thanks you.

 

2
Comment actions Permalink

I have the same problem with the last installer (2017.2)

I have used the MS tool but in the list the "JetBrains ETW Host Service" is missing!!!

In the services I have the "JetBrains ETW Collector 108.0.20170227.83302-eap03" service, also if I stop manually the service the installation fails.

If I try to reinstall the previous version (2017.1.3) all works fine, but I'm not able to upgrade on the last version.

Thanks for any support.

 

PS: This is a part of the log (sorry for some Italian messages inside)

08:36:58.204 |I| InstalledProductsDiscovery    | 6 per-user installations found (6 alive).
08:36:58.210 |I| SharedMsiUnification          | After: [Code: {B97607F7-A759-47F2-806C-4F7C14588944}, Version: 109.0.10.0, MsiPath: C:\Users\LuigiZ\AppData\Local\JetBrains\Installations\dotTrace09\Msi.x64\EtwService.msi], [Code: {B97607F7-A759-47F2-806C-4F7C14588944}, Version: 109.0.10.0, MsiPath: C:\Users\LuigiZ\AppData\Local\JetBrains\Installations\ReSharperPlatformVs14\Msi.x64\EtwService.msi], [Code: {B97607F7-A759-47F2-806C-4F7C14588944}, Version: 109.0.10.0, MsiPath: C:\Users\LuigiZ\AppData\Local\JetBrains\Installations\ReSharperPlatformVs15_4226f379\Msi.x64\EtwService.msi]
08:36:58.234 |I| SharedMsiUnification          | All upgrade codes: {B97607F7-A759-47F2-806C-4F7C14588944}
08:36:58.237 |I| SharedMsiUnification          | Upgrade code: {B97607F7-A759-47F2-806C-4F7C14588944}, max version: Code: {B97607F7-A759-47F2-806C-4F7C14588944}, Version: 109.0.10.0, MsiPath: C:\Users\LuigiZ\AppData\Local\JetBrains\Installations\dotTrace09\Msi.x64\EtwService.msi
08:36:58.238 |V| SharedMsiUnification          | installed msi: 108.0.6.0
08:36:58.239 |I| SharedMsiUnification          | All versions are older. Upgrade code {B97607F7-A759-47F2-806C-4F7C14588944}, path C:\Users\LuigiZ\AppData\Local\JetBrains\Installations\dotTrace09\Msi.x64\EtwService.msi
08:39:02.701 |E|                               | Errore irreversibile durante l'installazione.

--- EXCEPTION #1/2 [InstallerException]
Message = “Errore irreversibile durante l'installazione.”
ExceptionPath = Root.InnerException
msiErrorCode = 1603
ClassName = Microsoft.Deployment.WindowsInstaller.InstallerException
HResult = COR_E_SYSTEM=80131501
Source = Microsoft.Deployment.WindowsInstaller
StackTraceString = “
  in Microsoft.Deployment.WindowsInstaller.Installer.CheckInstallResult(UInt32 ret)
     in JetBrains.Platform.Installer.Services.SharedMsiUnification.<>c__DisplayClass21.<Unify>b__12()
     in JetBrains.Platform.Installer.Services.WindowsInstallerHelper.WithUacOnly(ILogger logger, Action action)
     in JetBrains.Platform.Installer.Services.SharedMsiUnification.<>c__DisplayClass21.<Unify>b__11()
     in JetBrains.Util.Logging.Logger.Catch(Action action)


--- Outer ---

--- EXCEPTION #2/2 [LoggerException]
Message = “Errore irreversibile durante l'installazione.”
ExceptionPath = Root
ClassName = JetBrains.Util.LoggerException
Data.ManagedThreadName = <NULL>
InnerException = “Exception #1 at Root.InnerException”
HResult = COR_E_APPLICATION=80131600
StackTraceString = “
  in JetBrains.Util.Logging.Logger.Catch(Action action)
     in JetBrains.Platform.Installer.Services.SharedMsiUnification.<Unify>b__7()
     in JetBrains.Util.Logging.Logger.Catch(Action action)
     in JetBrains.Platform.Installer.Services.SharedMsiUnification.Unify()
     in JetBrains.Platform.Installer.Services.SharedMsiUnification.<>c__DisplayClass4.<RunUnification>b__2()
     in JetBrains.Util.ILoggerEx.Catch(ILogger thіs, Action F, ExceptionOrigin origin, LoggingLevel loggingLevel)
     in JetBrains.Platform.Installer.Services.SharedMsiUnification.RunUnification(InstalledProducts productsAfter, IProgressIndicator pi)
     in JetBrains.Platform.Installer.Services.InstallerService.<>c__DisplayClass4.<Install>b__2()
     in JetBrains.Util.ILoggerEx.Catch(ILogger thіs, Action F, ExceptionOrigin origin, LoggingLevel loggingLevel)
     in JetBrains.Platform.Installer.Services.InstallerService.Install(InstallTargets targets, InstallerContext context, InstalledProductsDiscovery productsDiscovery, IProgressOwner owner, Boolean ignoreExtensions)
     in JetBrains.Platform.Installer.Models.InstallerViewModel.<GoInstall>b__2d(InstallTargets targets, IProgressOwner progress)
     in JetBrains.Platform.Installer.Models.ReadyToInstallPage.<GoInstall>b__2e(Lifetime lifetime, IProgressOwner owner)
     in JetBrains.Platform.Installer.Models.InstallerPageWithProgress.<>c__DisplayClass8.<RunAction>b__3()
     in JetBrains.Util.Logging.Logger.Catch(Action action)
     in JetBrains.Platform.Installer.Models.InstallerPageWithProgress.<>c__DisplayClass8.<RunAction>b__2()
     in JetBrains.Util.Logging.Logger.Catch(Action action)
     in JetBrains.Platform.Installer.Models.InstallerPageWithProgress.<>c__DisplayClass8.<RunAction>b__1()
     in System.Threading.ThreadHelper.ThreadStart_Context(Object state)
     in System.Threading.ExecutionContext.RunInternal(ExecutionContext executionContext, ContextCallback callback, Object state, Boolean preserveSyncCtx)
     in System.Threading.ExecutionContext.Run(ExecutionContext executionContext, ContextCallback callback, Object state, Boolean preserveSyncCtx)
     in System.Threading.ExecutionContext.Run(ExecutionContext executionContext, ContextCallback callback, Object state)
     in System.Threading.ThreadHelper.ThreadStart()


08:39:02.861 |I| InstallerService              | Starting final clean up.
08:39:02.861 |V| InstallerService              | Removing unused packages.
08:39:02.865 |V| InstallerService              | Packages in use
08:39:02.865 |V| InstallerService              |   jetbrains.dotcover.standalone.109.0.20170824.140432

___________________________________________________

As last operation I have tried to delete manually the service but also in this case I'm not able to install correctly the EWT service

0
Comment actions Permalink

Additional information on my problem.

My user does not have the Administrator privileges, and I think this is the problem.

If I install the dotTrace by running the installation with and user with Administrator rights, the installation works fine and the EWT service is installed correctly, but if after I try to repair the installation on the normal user I have the same error message (also if the service is correctly installed with the previous installation).



 

0
Comment actions Permalink

Probably I found the solution.

In the registry, under the "HKEY_USERS\S-1-5-21-xxx-xxx\Software\Microsoft\Installer\Products\" was present the node "DD2EB8C7C5F7A9849B0984DC89239DE7" related the "JetBrains ETW Host Service" (old installation)

To allow the correct installation I have deleted this node (after a backup for security), repaired the installation, and now magically the installation is completed without any problem, also the ETW service!

After this new installation, under Products, I have the new node "E0B97671A860479438BCC6C355A63321" with the correct path to the MSI file.

3
Comment actions Permalink

I've just experienced a very similar issue which relates to the elevated permissions required in our company to install the DotTrace program in Resharper 2019.2.2

When you install the program as a normal user everything seems to be installed to C:\Users\user\AppData\Local\JetBrains\Installations\dotTrace192\Msi.x64\EtwService.msi but when you switch to the elevated user this folder is not accessible and the installer will not use a subst or network directory

 

0

Please sign in to leave a comment.