How to prevent ReSharper C++ automatically startup in C# projects?

I just need to use ReSharper C++ in C++ projects, but it startup in C# projects and slow down my Visual Studio running speed seriously. Besides, ReSharper C++ has overrided Visual Studio quick actions so in C# projects the quick action is unavailable.

Please help me to solve this problem. Thanks!

6 comments
Comment actions Permalink

Hello,

To disable C# support you can turn off "ReSharper" on the "Products & Features" settings page.

You can also configure ReSharper so that VS actions are available if you want to.

0
Comment actions Permalink

Hello, thanks for reply.

I just installed ReSharper C++ and have not installed ReSharper, so I don't need to disable C# support. I just want to prevent ReSharper C++ from starting up automatically in C# or other non-c++ projects because it makes VS really slow in starting up.

If there's no way to solve this problem, please tell me how to configure ReSharper for VS quick actions.

0
Comment actions Permalink

Try the "Merge VS Quick Actions" setting. If that's not what you want to achieve, please describe the issue in more detail.

0
Comment actions Permalink

I have checked "Merge Visual Studio Quick Actions into ReSharper action indicator", and it seems no use. Then I also checked "Force getting Visual Studio Quick Actions",the problem still exists. The screenshot is shown below.

The first picture is produced by pressing Alt+Enter and the ReSharper C++ quick action showed. The second picture is produced  by clicking the Visual Studio Quick Action icon.

And this is my setting.

0
Comment actions Permalink

Thanks! It looks like there's some kind of issue in this scenario, we'll investigate. The Alt+Enter menu is supposed to look like this with VS actions merged:

I've created https://youtrack.jetbrains.com/issue/RSRP-488756/Roslyn-actions-do-not-get-shown-in-the-Alt-Enter-menu-when-R-is- to track this issue. As a workaround, you can use Ctrl-. to open the list of VS actions, or rebind Alt+Enter to open the VS list for now.

0
Comment actions Permalink

Another option of course is to enable C# support in ReSharper and give it a try :) In this case VS actions should be properly merged into ReSharper's Alt+Enter menu.

0

Please sign in to leave a comment.