Why does the Build & Run window KEEP jumping to the foreground???????

At various times, usually after ending a debugging session, or opening Visual Studio intially, the Build & Run window keeps jumping to the foreground. I have it tabbed with the Solution Explorer and Git Changes windows, and to be honest, I don't need to see that window ever, unless there are problems. It's really annoying to have it keep jumping to the foreground like that.

4 comments
Comment actions Permalink

Hello Doug Belkofer,

Could you please record a video of such behavior? Thank you in advance.

0
Comment actions Permalink

I think I figured this out - for solutions where I am using Resharper build, when I initiate a debugging session, it switches to that window to do the build. Then, upon ending the debugging session, since that window was in front before starting debugging, it is in front upon ending debugging. I have a solution where I am not using Resharper build, and when I debug that solution the resharper build window does not come to the foreground.

I think my frustration is that almost all of the time, when I end a debugging session, I am about to navigate to some file to make some changes, or I want to interact with the Solution Explorer or Git Changes window. It is annoying to me that for solutions where I am using the Resharper build, I have to switch to the Solution Explorer or Git Changes window first. Not sure what the best solution is here - maybe don't switch to the Resharper Build & Run window unless there are problems with the build? Maybe never force it to the foreground? I can always switch to it if I want.

0
Comment actions Permalink

I have found a way to not have the build window come to the foreground when a build happens: In Resharper Options, go to Tools, Build, Presentation, and uncheck the item named "Tool Window: when build starts, open the build progress view in a tool window".

1
Comment actions Permalink

Hello Doug Belkofer,

Thanks for sharing your findings. We are glad to hear you found the solution to stop this behavior.

 

0

Please sign in to leave a comment.