ReSpeller no longer working in Visual Studio 2019 or Rider?

Answered

Recently, the ReSpeller option has stopped working in Visual Studio 2019. I also noticed it is not working in Rider either. It is enabled it VS 2019 and Rider. I have no idea why it has stopped. 

Visual Studio 2019.16.11.3 (I updated today hoping it would fix the issue) 



9 comments
Comment actions Permalink

Hello Daniel,

 

Could you please check that ReSpeller is enabled in:

  • ReSharper | Options | Environment | Products & Features
  • ReSharper | Options | Tools | ReSpeller.

Thank you.

0
Comment actions Permalink

Products & Features:

Respeller:

0
Comment actions Permalink

Thank you for the info.

Does it happen in some specific solution only? Could you please check if it happens in a newly created project?

0
Comment actions Permalink

I've tried new and existing solutions. It's really strange. 

0
Comment actions Permalink

What about other spellchecker features? Are spelling issues highlighted in other cases?

Please check that "Typo in comment" inspection is enabled.

0
Comment actions Permalink

Hello Daniel,

Could you please provide all dotSettings files via ``ReSharper | Manage Options | right-click on each layer | Export to file``.

You can share it using our upload service - https://uploads.jetbrains.com

0
Comment actions Permalink

Upload ID: 2021_09_17_Tw5am9YjJGhLMMu9 (file: ResharperSettings.zip)

0
Comment actions Permalink

Hello Daniel,

You have got the following option disabled - ReSharper | Options | Code Inspection | Settings | Enable code analysis in computer wide settings.

Any ReSharper inspection doesn't work when this option is disabled so please reenable it.

Let me know if you have any more questions.

Thank you.

0

Please sign in to leave a comment.