Rider wants to default to System.Random in Unity

Every time I introduce Random.Range(min, max) into a new cs file in Unity, if I'm not hypervigilant, Rider adds 

using Random = System.Random; 

to the usings clauses, and of course Random.Range breaks.   I've paid a bit more attention, and it appears that no matter what I do, the Intellisense displays Random (in System) as the first option, so if you keep typing, it assumes that this is what you want.  It's not.  When in Unity, it's never ever what I want.   Even if I remove using System; it keeps trying to do this.  When I code, especially on boilerplate stuff like a quick Random.Range(), I usually just plow through, this is slowing me down, which is opposite of what I use Rider for.  

Is there a fix for this?

1 comment
Comment actions Permalink

Hello,

Could you please check if Machine Learning-Assisted Completion is enabled in Preferences | Editor | General | Code Completion, if not you can try enabling it or clear caches to drop statistics. After that it should suggest what you choose more often. Please keep me posted on the results. 

0

Please sign in to leave a comment.