Resharper (2021.1.4) Performance/IDE display issues VS2019 (16.10.3)


Since updating visual studio last week, I've been experiencing a slew of problems, I've reverted my build to the previous version of Visual Studio, without resolution to the issue. Upon diagnostic, I can disable Resharper to resolve my issue for now, however this is not ideal.


  • Parameter Names appear blank (no text in those sections) [I commented this on another user's existing submission]
  • IDE freezes when typing Parameters/Attributes, then repeats characters between 64-256 times, causing ide to freeze, then process the next character (GIF at x100 speed). 
  • IDE window turns to theme backdrop colour. Text cannot be highlighted, cannot be selected, and not editable. (Resolved by restart)
  • IDE window showing contents strangely (replicated example)
  • Line numbers incorrect/broken
  • Paste operation will periodically cause repeated pastes to occur in the same file (will continuously paste until application crash). No screenshot is available. File in image was originally 50 lines.


Version Information:

  • JetBrains ReSharper 2021.1.4 Build 211.0.20210706.71525 built on 2021-07-06
  • ReSharper 2021.1.20210706.80915
  • Visual Studio Enterprise 2019 (Version 16.10.31424.327, InstanceId 222994e8).

Debug steps attempted:

  • Disabled Visual Studio AI Assist Intellisense (reduced frequency of event)
  • Disabled Solution Wide analysis
  • Cleared Cache
  • Fresh install Visual Studio
  • Fresh install Resharper
  • Full restart between each stage
  • Created Test Console App (Successfully replicated in a near empty console app)
  • Disabled Resharper (All issues resolved)
Official comment

Hi all!

We've just released the 2021.1.5 bugfix.
Please download it here and check how it works for you.
Thank you!

Same issue here with 2021.1.4 (and VS 2019 Enterprise - 16.10.3).

2021.1.4 is unusable for me and I rolled back to 2021.1.3 which work a lot better.


Just updated to 2021.1.4. Immediately had blank parameter names and freezing IDE. Disabled Resharper, fixed issue. I would like to roll back.


Hello Aseeds, David Slade, Björn Müller, Joakim Evers, Henryk Wisniewski, Scorchen,

We're very sorry for the inconvenience. We're going to release 2021.1.5 with a fix for these problems (inlay hints and freezes) as soon as possible. As a workaround, please disable Inlay Hints in ReSharper | Options | Environment | Inlay Hints | General or downgrade to 2021.1.3.

Thank you!


Looking forward to 2021.1.5

Don't beat yourself up too bad - I always update ReSharper as soon as possible and this is the first time I've had to rollback


Workaround worked. It is rare we have breaking issues like this with Resharper.


Hello David Taylor,

Thank you for the feedback. We’ll be releasing a fix for it this week. Sorry for the inconvenience!


Same thing here, absolute corruption, especially when inlay hints are enabled. Random freezes, cannot change cursor placement, cannot write, etc.


Only got as far as figuring out the breakpoints and line numbers were not keeping up before looking to submitting VS feedback as I'd just upgraded VS 2019 to current version.  R# problems happen so rarely, I didn't even think that might be the problem.  Rollback to 2021.1.3 fixed it and I'll wait until .5 before looking to update again.


I also have this issue.

Sorry, I opened duplicate issue here: 

You can delete the duplicate issue

Anyway, I recorded it so you can see and verify that I am getting the same issue:


2021.1.5 works for me. Thank you !


Thank you for fixing this. It was a nightmare this past week.

What's being done to prevent this sort of issue in the future, please?


Same problem here, first time I ever had to rollback to a previous version.  The rollback worked like a charm, so that's good.


For what it's worth, confirmed same symptoms and had to rollback as well. Thanks for promising to address this swiftly


Hello Auri,

Thank you for the feedback. We did everything to deliver the bugfix as soon as possible.
So, we've analyzed the flaws in our release procedure that led to releasing 2021.1.4 the way it is; and we won't repeat them.
Apologize again for this situation.


Elena Kurakina Understood, thanks!


Thought I was going mad trying to live with this issue.

Great to find out is was resharper and a link to the update via this post. Thanks !


Same here: Installed 2021.1.4 -> immediate devastation


Hello Gileli121,

Thank you for the information. The duplicate issue was deleted.

You can find the workaround here.




Where to find the previous (far less buggy and less damaging) release please?


Found it...  and select 2021.1.3


It's a shame the JetBrains toolbox doesn't offer this...


Ryan O'Dell - I rolled back using the toolbox.  Use the three dot menu to the side of ReSharper Tools and it should be available.



Unfortunately my toolbox didn't have any earlier versions, only the 2021.1.4 & the next EAP version 😕


Hello Simonjackson Info,

Glad to hear!

You are always welcome.


Same issue and this crap is happening often enough that I'm going to start doing my best to not require resharper anymore.


Please sign in to leave a comment.