Resharper is unable to resolve symbol for 'HttpClient' and many other symbols from System.Net.Http in Visual Studio 2019

Holy Cow! I've tried everything... Spent 4 hours and counting trying to fix this issue. Here's what I've tried...

What's Happening?
I get syntax errors when the solution builds and compiles successfully. If I disable resharper the syntax red highlighting goes away.

What have I tried?
1. Suspending and Resuming resharper

2. Suspend, clear cache button, restart VS, resume

3. Suspend, clear cache button, manually navigating to and deleting solution caches, restart vs, resume resharper

4. Suspend, clear cache, disable and re-enable ReSharper | Options | Environment | General | Read solution model directly, restart VS, resume

5. Uninstalled Resharper, Reinstalled, cleared all caches (using the button in VS and the solution caches), deleted the .vs file

Please someone help!!!!

1 comment
Comment actions Permalink

Hello Matthew Newbill 353,

I would be glad to assist you! 

Could you please submit a support request via the form?



Please sign in to leave a comment.