How do I disable templates on tab?

When I press Tab after a keyword it inserts a template. For instance "else<tab>", inserts a set of braces.

Is Resharper C++, or Visual Studio doing this?

Either way, how can I turn it off?

2 comments
Comment actions Permalink

Hello,

R++ does expand live templates from completion, but in this case this is probably VS. Try turning off "Use tab to insert snippet" in Tools | Options | Text Editor | C++ | Advanced.

0
Comment actions Permalink

Thanks, that was it.

Even though Intellisense was disabled, it was still using the greyed-out options.

0

Please sign in to leave a comment.