MSTest unit tests not detected in Visual Studio Version 16.7.0

Completed

I've just updated Visual Studio to Microsoft Visual Studio Professional 2019 Version 16.7.0 and Resharper no longer detects MSTest unit tests.

To reproduce:

  1. Extensions -> ReSharper -> Unit Tests -> Run All Tests from Solution
  2. Solution is rebuilt
  3. Unit Test Sessions window shows 0 tests detected.

NUnit tests are still detected

10
22 comments

Hello David,

 

thank you for the feedback.

Could you please try the latest ReSharper 2020.2 EAP build - https://www.jetbrains.com/resharper/nextversion/ and check the issue once again?

Thank you.

1

Experiencing this same issue. Did not see this request until after filing my own. Eagerly awaiting a proper fix.

1

Same here, since upgrading to visual studio 16.7.1, MS Unit Tests are no longer discoverable. 

1

Hello Andwan,

 

Please install the latest ReSharper 2020.2 and check the issue once again.

Thank you.

1

Hi Angelina,

This EAP build of ReSharper 2020.2 fixes the issue.

Thanks,

David

0

Follow-up: although the tests are discovered and can be run they cannot be debugged. Using the Debug Unit Test command from either the test explorer or from the source code results in the code being simply run and not debugged.

0

Hello David,

 

thank you for the reply. 

Do you use EAP 9? 

Could you please run Visual Studio with the following command line: devenv /ReSharper.LogFile C:\log\resharper_log.txt /ReSharper.LogLevel Verbose, reproduce the issue and send us a corresponding 'resharper_log.txt' file. You can do it privately via "Submit a request" form.

Thank you.

0

ReSharper is JetBrains ReSharper 2020.2 EAP 9 Build 202.0.20200805.121311-eap09 built on 2020-08-05. I'll submit a request containing the log file.

0

this is crazy, first time everything is totally broken after stable release :-/

0

We have the same issue. Please let me know if it would help you if I also test the EAP.

(FYI, I'm the one who has reported it to the vs-devteam mentioned by Plock)

0

Hello N. Plock and Bas Scheutjens

 

Yes, please try the latest ReSharper 2020.2 EAP9 build as it contains many unit testing changes -https://www.jetbrains.com/resharper/nextversion/#section=windows.

Please let me know about the results.

Thank you.

 

0

Hi Angelina,

I've tried EAP9 and it appears to work perfectly, both Run and Debug. I've tried starting the unit tests from the various context menu options and the regular menu options and they all seem to work.

By the way, I had to reinstall the latest Visual Studio version because I downgraded to 16.6.5, so I have tested this with Visual Studio 16.7.1 Community edition (released earlier today).

Hope this helps

0

Hi,

same here, discovery/run/debug works fine again with EAP 9, for both VS 16.7.0 and 16.7.1.

We also tested the VS-Update 16.7.1 with ReSharper 2020.1.4, it does not fix the issue.

0

Thank you for letting me know.

We are planning to release ReSharper 2020.2 in a couple of days so you are welcome to install release build once it's published.

Feel free to contact us in case of any questions or problems.

 

0

I was having the same issue which existed in 2020.1 and a prior 2019.x version. What was strange is for a while I had been seeing this issue with new VS Solutions and eventually the tests would be discovered after explicitly opening any test class file of each test project.

Anyway...

Installing 2020.2 resolved the issue for me. 

 

I did not have this problem when creating test projects using .net core, the problem was only seen (tested against) in projects using .net framework 4.7.2

0

I have this problem in version 2019.2.4 but I do not have 2020.2 licence. Will I be forced to pay one upgrade to get a bug fix!??

0

Rodrigo Cesar Santos, sorry for that :( Visual Studio 2019 is under active development and VS releases bring changes that aren't compatible with the previous ReSharper versions. 

0

I can't run the EAP package to fix the problem. Win 10 simply shows a popup about MS Store. And a link to info about running apps outside store. Anyone encountered this?

Worth noting, that I don't get this if attempted to repair Resharper installation via Settings -> Apps&Features

0

Hello Sumith,

Do you get this after downloading and running 2021.1 EAP installer from here?

0

Please sign in to leave a comment.