How can I make ReSharper C++ work properly with Unreal Engine

ReSharper C++ has been amazing in normal C++ development, but it wasn't the best in Unreal Engine development. 
Reasons: 
1- Each time I add a new class there are red squiggles and no syntax highlighting in that class's files .
2- Sometimes it lags while I'm writing code.
3- Each time I open an Unreal Engine solution Visual Studio 2019 stops responding for a few seconds and it blames the ReSharper C++ extension.
However, I can handle number 2 and number 3, but I can't handle number 1. It's very annoying to have to regenerate visual studio project files each time I add a new class. There must be a way to fix this. Could downloading the EAP2 build fix this problem? Any Help would be appreciated.

2 comments
Comment actions Permalink

Hello,

For 1, please install the latest EAP build, enable the "Use Unreal Engine project model" and open your solution after that. If you still experience bogus errors after adding new files, please let us know.

For 2, if you can somehow reproduce the lags, please try to capture them on performance snapshot (https://resharper-support.jetbrains.com/hc/en-us/articles/210652849-Collect-Timeline-performance-snapshot-in-Visual-Studio). and we'll take a look. Disabling "Index UE source files" in the above settings page should also help.

Please also note we have a separate support forum for ReSharper C++ (https://resharper-support.jetbrains.com/hc/en-us/community/topics/200366089-ReSharper-C-), please post C++-related questions there.

Thanks!

0
Comment actions Permalink

Igor Akhmetov Thank you, that worked. project loading speeds are faster now, and the red squiggles are gone.

 

0

Please sign in to leave a comment.