Resharper cannot resolve symbols in Visual Studio 2019

Answered

Why can't resharper resolve my symbols (See the red symbols in the screenshot below. Even a simple HttpGet is not resolved.) ? I have cleared the cached a number of times. Is there any setting that I need to set? The project is using .Net Framework 4.5.2. This is getting annoying as the intellisense is not helping me right now.

 

11 comments
Comment actions Permalink

Hello Edward,

 

Could you please try disabling ReSharper via VS Tools | Options | ReSharper Ultimate | Suspend and check if the issue goes away?

Thank you.

0
Comment actions Permalink

This is exactly my problem.  I can answer yes if I disable Resharper, the problem goes away.  When I re-enable Resharper it comes back.  Is there an update to fix this?

0
Comment actions Permalink

Hello Scott Kelley,

 

Could you please try the following actions and check if any of them helps:

1. clear caches via ReSharper | Options | Environment | General | Clear Caches 

2. disable the following option - ReSharper | Options | Environment | General | Read solution model directly.

Please let me know about the results.

Thank you.

 

0
Comment actions Permalink

I had tried #1 to no avail.  I had not tried #2.  What I wound up doing yesterday afternoon was upgrade my resharper version to the last 2019 release.  So far, everything seems to be working.  However, if it starts again, I will try the steps you mention.

0
Comment actions Permalink

This STILL has not been fixed and has been happening for YEARS. It has so far happened for me with three different systems of three completely different environments and configurations. 

Has the Resharper project been abandoned or has the development team just decided to not fix this issue? This breaks core functionality and has been happening for years with no actual fix. 

Clearing caches do not work- The only thing seems to work is reinstalling a fresh copy of Windows as it takes far too long to triage all the junk files left over after uninstalling Resharper to ensure it does a clean install- because even reinstalling resharper does not fix this issue. Nuking the operating system is not a solution, 

0
Comment actions Permalink

Hello Bitz,

The reasons for the red code can be different, we try to quickly fix the cases that we become aware of.

ReSharper is definitely isn't abandoned, we are working hard on improving ReSharper.

Which ReSharper version are you using (ReSharper | Help | About JB ReSharper)? Do you have a chance to take a screenshot of the whole VS window including the vertical scrollbar where the problem will be shown?

Thanks in advance!

0
Comment actions Permalink

I am also very frustrated with this, it has been plaguing us for years and at least 3 VS versions. I am running VS 2019 16.9.1 and R# 2020.3.3. I have tried all the variations on cache clearing, suspending, resuming, refreshing, retargeting, as listed here but none of it has solved the problem. 84 errors in 3 files forever. In my case they are names defined in xaml that we are accessing in the code behind.

<MenuItem Name="_menuItemBarLabelFontSize" Header="Bar Label Size">
<ComboBox Name="_comboBoxBarLabelFontSize" StaysOpenOnEdit="True" MinWidth="100" SelectionChanged="OnBarLabelFontSizeSelectionChanged" />
</MenuItem>

then in the code behind, where ever we access _comboBoxBarLabelFontSize or _menuItemBarLabelFontSize, Resharper says it can't resolve it,  though it builds and runs perfectly. Tips?

0
Comment actions Permalink

Hello M L Robbins,

Could you share a sample solution triggering this? You may submit it alongside a support ticket, created by the "Submit a Request" button above.

As a suggestion, it's worth trying to disable the setting: ReSharper | Options | Environment | General | "Read solution model directly from project/solution files". In case it helps, we'll need project model dumps collected as described here: https://resharper-support.jetbrains.com/hc/en-us/articles/360018389180-How-to-get-dumps-and-logs-for-ReSharper-s-project-model-problems

0
Comment actions Permalink

Had the same problem, nothing mentioned above did help. Enabling Options | Environment | Products & Features | Web Languages solved the problem.

0
Comment actions Permalink

Hello Klirium

Does it happen for JS/TS project? Did you try to disable the setting: ReSharper | Options | Environment | General | "Read solution model directly from project/solution files"?

0
Comment actions Permalink

Turns out our problem was in our code. Wherever we had

<MenuItem Name="_menuItemBarLabelFontSize" Header="Bar Label Size">

I changed it to use "<MenuItem x:Name..." and now life is perfect again. Green checkbox from Resharper. Can't believe we missed that for so long.

0

Please sign in to leave a comment.