Code Cleanup unavailable [in ReSharper Ultimate & VS2019 Professional]

Completed

I have just noticed that Code Cleanup has disappeared. I code exclusively in C#.

I am using:

  • Visual Studio Professional 2019 (16.3.6)
  • Resharper 2019.2.3 built 2019-10-16
  • I have the following Resharper extensions installed: JetBrains.ExternalAnnotations, StyleCop by JetBrains

Whenever I try to invoke the code cleanup chord Ctrl+E, Ctrl+C I see the following in the status bar: "The key combination (...) is bound to command (ReSharper_CleanupCode) which is not currently available", Similarly, 'Code Cleanup' is missing from the context menu. This is for all files and, specifically, for code file written by me (i.e. not delivered by NuGet, or marked as generated). I am using the same .DotSettings file that I have been using successfully for months and this includes custom clean up configurations.

I have tried changing the .DotSettings file to use an alternative key regime and then reverting to ReSharper. When I then hit the key chord Ctrl+E, Ctrl+E ReSharper warns of a conflict and lists several commands. I choose "Use ReSharper Ultimate command" and check the checkbox to do this for all and then click OK but nothing happens.

Why is this command no longer available? For me, it's one of ReSharper's most useful features and it's killing me!

Thanks

3 comments
Comment actions Permalink

Hello Mark,

 

Is the issue reproduced in a newly created solution?

Could you please run Visual Studio with the following command line: 'devenv /ReSharper.LogFile c:\log\resharper.log /ReSharper.LogLevel Verbose', reproduce the issue and send us a corresponding 'resharper_log.txt' file. You can share it privately via 'Submit a request' form.

Thank you.

0
Comment actions Permalink

Angelina,

Thank you for your swift response. I just updated Visual Studio to 16.3.7 and repaired my ReSharper Ultimate installation and everything now appears back as normal. I had performed a repair of ReSharper before contacting you but it appears that the combination of the two installations has solved the issue.

Thanks

0
Comment actions Permalink

Thank you for letting me know, Mark.

0

Please sign in to leave a comment.