Switch Header/Source won't work if header has a non-standard file extension

Where I work, header files that use QT have the extension ".hq". I'm not sure why they do this but it is preventing the Toggle Header/Source command from working.

I've made sure to add this extension as a C++ file in Options / Text Editor / File Extensions but still no luck. I've tried both: Visual Studio's "ToggleHeaderCodeFile" and Resharper's "SwitchHeaderSource" but none work which is very strange as everything else seems to work; like Goto Symbol (F12) will take me to the header file.

Is there a fix for this?


Comment actions Permalink


We can fix the "Switch Header/Source" action so that it works with parsed files which have a non-standard extension (https://youtrack.jetbrains.com/issue/RSCPP-27509). But note that the set of file extensions that R++ recognizes is fixed at the moment, so the rest of the functionality will still not work in ".hq" files.


Comment actions Permalink

Why not add a way of allowing users to define non-standard file extensions? I've been told that using different file extension in common practice for a variety of reasons and even your competitor has a way of enabling them:



Please sign in to leave a comment.