Can I get autocomplete feature to popup immediately instead of the delay that I get.

Hi,

 

I am having some trouble with the auto complete with Resharper.

I used to use Visual Assist X and am switching full time to Resharper due to some features I like. I however miss when I do not have to wait a couple of seconds for the auto complete to kick in in Visual Assist.

This is how it works now in Resharper,

 

I however, do not want to wait for the suggestion lists. I want to type half the word and hit tab to complete and move on. Similar to how you would do in Bash, VAX and other software. I'm sure there is an option that I missed. Can someone please let me know if it is possible.

 

I changed the following option, but it doesn't seem to effect it. I can't get it to go down from 10 ms to 0.

 

 

6 comments
Comment actions Permalink

Hello,

Unfortunately, this is probably just completion being slow on this particular file. You can check by completing in an empty file, the completion dropdown should appear instantly. Could you please capture a few slow completion sessions on a performance trace and send it to us for investigation? The instructions are at https://resharper-support.jetbrains.com/hc/en-us/articles/210652849-Collect-Timeline-performance-snapshot-in-Visual-Studio.

If completion speed bothers you too much, you can switch to using VS completion in "ReSharper | Options | Environment | IntelliSense | General".

Thanks!

1
Comment actions Permalink

I sent the report. And I disabled that option which made it much faster. But this removes the parenthesis completion for methods.

 

Using the Resharper Auto complete, and then using the visual studio auto complete.

 

I have this option set in both the cases.

Is there a way I can get it to work again.

0
Comment actions Permalink

Sorry, ReSharper's completion options do not affect Visual Studio IntelliSense.

0
Comment actions Permalink

Sorry, we can't seem to find the performance report you submitted. Could you please let us know the user account you submitted it under, or was it anonymous?

0
Comment actions Permalink

Nevermind, I was looking in the wrong place - thanks again!

0
Comment actions Permalink

I took a look at the snapshot, and the longest completion pause I see there is about 350ms, which is not great but also does not look like the delay in your screencast which is more than a second. I've also noticed that you have VAX enabled - could you please check if completion appears faster if you disable VAX?

0

Please sign in to leave a comment.