Unable to resolve dependency 'Wave (≥ 1.0.0)'

10:04:04.534 |E| ExtensionManagerViewModelProvider| :59 | Unable to resolve dependency 'Wave (≥ 1.0.0)'.

--- EXCEPTION #1/2 [InvalidOperationException]
Message = “Unable to resolve dependency 'Wave (≥ 1.0.0)'.”
ExceptionPath = Root.InnerException
ClassName = System.InvalidOperationException
HResult = COR_E_INVALIDOPERATION=80131509
Source = NuGet.Core
StackTraceString = “
в NuGet.InstallWalker.OnDependencyResolveError(PackageDependency dependency)
в NuGet.PackageWalker.Walk(IPackage package)
в NuGet.InstallWalker.ResolveOperations(IPackage package)
в NuGet.PackageManager.Execute(IPackage package, IPackageOperationResolver resolver)
в NuGet.PackageManager.UpdatePackage(IPackage newPackage, Boolean updateDependencies, Boolean allowPrereleaseVersions)
в JetBrains.UI.SrcView.Extensions.View.ExtensionManagerViewModelProvider.<>c__DisplayClass17_3.<get_Model2>b__26()
в JetBrains.Util.ILoggerEx.Catch(ILogger thіs, Action F, ExceptionOrigin origin, LoggingLevel loggingLevel)

--- Outer ---

--- EXCEPTION #2/2 [LoggerException]
Message = “Unable to resolve dependency 'Wave (≥ 1.0.0)'.”
ExceptionPath = Root
ClassName = JetBrains.Util.LoggerException
Data.ManagedThreadName = <NULL>
InnerException = “Exception #1 at Root.InnerException”
HResult = COR_E_APPLICATION=80131600
StackTraceString = “
в JetBrains.Util.ILoggerEx.Catch(ILogger thіs, Action F, ExceptionOrigin origin, LoggingLevel loggingLevel)
в JetBrains.UI.SrcView.Extensions.View.ExtensionManagerViewModelProvider.<>c__DisplayClass17_3.<get_Model2>b__24()
в JetBrains.UI.SrcView.ExtensionManager.ViewModels.ExtensionActionViewModel.Do()
в JetBrains.UI.SrcView.ExtensionManager.ViewModels.ExtensionManagerViewModel.<BeginInstallation>b__91_0(ProgressIndicator indicator, Property`1 description)
в JetBrains.UI.SrcView.ExtensionManager.ViewModels.ProgressPage.<>c__DisplayClass18_0.<Run>b__1()
в System.Threading.ThreadHelper.ThreadStart_Context(Object state)
в System.Threading.ExecutionContext.RunInternal(ExecutionContext executionContext, ContextCallback callback, Object state, Boolean preserveSyncCtx)
в System.Threading.ExecutionContext.Run(ExecutionContext executionContext, ContextCallback callback, Object state, Boolean preserveSyncCtx)
в System.Threading.ExecutionContext.Run(ExecutionContext executionContext, ContextCallback callback, Object state)
в System.Threading.ThreadHelper.ThreadStart()

 

6 comments
Comment actions Permalink

Hello,

 

Thank you for the feedback.

We are aware of the problem and working on the fix. New ExternalAnnotation package should be updated on our server and appear on your machines in few days.

Thank you.

0
Comment actions Permalink

I have package update for extenrla annotaion 

 

Is this the fixed version ? 

 

0
Comment actions Permalink

Hello Royi,

 

Thank you for the feedback.

Could you please specify ReSharper version you are using?

Thank you.

0
Comment actions Permalink

@angelina

Hi - I've downgraded to 1.2 becuase of this ^ problem in 1.3
question is , can I install the latest version now ? 


0
Comment actions Permalink

Yep, you can install the latest ReSharper 2019.1.3, the problem is fixed in it.

Thank you.

0

Please sign in to leave a comment.