Unable to find version '183.0.20181226.120010' of package 'JetBrains.Psi.Features.Diagramming'.

Hi ReSharper,

I have cloned my project from VSTS Git. I have been trying to restore and/or build the solution, however, it is failed with the following error.

 

NuGet Package restore failed for project app\path: Unable to find version '183.0.20181226.120010' of package 'JetBrains.Psi.Features.Diagramming'.
C:\Program Files (x86)\Microsoft SDKs\NuGetPackages\: Package 'JetBrains.Psi.Features.Diagramming.183.0.20181226.120010' is not found on source 'C:\Program Files (x86)\Microsoft SDKs\NuGetPackages\'.
https://api.nuget.org/v3/index.json: Package 'JetBrains.Psi.Features.Diagramming.183.0.20181226.120010' is not found on source 'https://api.nuget.org/v3/index.json'.
. Please see Error List window for detailed warnings and errors.

 

Below are the ways I have tried to resolve this:

1. Reinstalled the ReSharper; cloned the code base; and did nuget package restore - same error.

2. Did #1 by removing temporary files.

3. Verified packages under ..projectpath/packages folder which has other dependencies installed, for instance JetBrains.Psi.Features.Core.183.0.20181226.120010. However, there is no JetBrains.Psi.Features.Diagramming installed.

 

Versions:

1. JetBrains.ReSharperUltimate.2018.3.4

2. .Net Framework 4.6.1

Please provide assistance to resolve this issue.

6 comments
Official comment

Hi Tirumalesh Tamarana!

Due to some internal changes you need to reinstall ReSharper SDK package in your plugin project.

As I mentioned in the post, I did the same. I reinstalled the latest version.

 

Please let me know if I need to get any specific old versions or need to take the order of ReSharper installation?

0

You've reinstalled ReSharper itself, but I've been talking about R# SDK package.
You need to remove all references to R# SDK from your plugin project and install necessary version from scratch.

 

0

Here are the steps what I followed:

Step 1: Initially downloaded JetBrains.ReSharperUltimate.2018.3.4.exe from https://www.jetbrains.com/resharper/download/

Step 2: As build was failed, uninstalled it from control panel with name JetBrains.ReSharperUltimate.

Step 3: Cloned code to new path and installed JetBrains.ReSharperUltimate.2018.3.4.exe again.

Step 4: Tried building/restoring the packages, still build failed with mentioned errors.

 

Is JetBrains.ReSharperUltimate.2018.3.4 is the SDK or am I missing anything?

 

Please guide.

0

No, exe is not SDK, it's ReSharper itself.

ReSharper SDK is package which is referencing in your plugin project.

Did you write it itself? How did you created it in first place?

Repeat that actions with the latest SDK.

0

I appreciate your guidance.

After uninstalling the ReSharper Ultimate extensions, I tried to install ReSharper SDK using package console >Install-Package JetBrains.ReSharper.SDK -Version 2018.3.4. However, the installation was failed with the following error message.

 

Install-Package : Some NuGet packages are missing from the solution. The packages need to be restored in order to build the dependency graph. Restore the packages before
performing any operations.
At line:1 char:1
+ Install-Package JetBrains.ReSharper.SDK -Version 2018.3.4
+ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
+ CategoryInfo : InvalidOperation: (:) [Install-Package], InvalidOperationException
+ FullyQualifiedErrorId : NuGetMissingPackages,NuGet.PackageManagement.PowerShellCmdlets.InstallPackageCommand

 

Please let me know how to install SDK using package console or any other way by standalone download(provide link).

 

0

Please sign in to leave a comment.