How to run ReSharper CLI tools on Mono?

Answered

Thank you very much for making these tools free to use. But, how can I run the CLI tools on Mono on Linux?

Two different distributions are tried, with this command "mono dupfinder.exe --help".

----

I) Debian 9, this is my target system:

I have installed "mono-runtime", "libmono-system-drawing" and "libmono-system-xaml" to satisfy all prerequisites. But now I get this exception from Mono:

"* Assertion at local-propagation.c:330, condition `ins->opcode > MONO_CEE_LAST' not met"

Mono has the version 4.6.2 (Debian 4.6.2.7+dfsg-1).

----

II) Current Manjaro (Arch derivate), just to try a newer Mono:

I have installed "mono" and "mono-addins" (and "monodevelop-stable"out of curiosity). Mono tells me now that it "Could not load file or assembly 'PresentationCore, Version=4.0.0.0, ...' or one of its dependencies." I have no idea which package contains "PresentationCore".

Mono has the version 5.18.0 (makepkg/5266e6a8f10).

----

Is there something in the CLI tools that prevents them from running on Mono?

2 comments
Comment actions Permalink

Oh, just found https://youtrack.jetbrains.com/issue/RSRP-466029 that explains a lot.

Are there plans to make the tools run on Mono in the near future?

0
Comment actions Permalink

Hello Bodo!

 

Mono support directly depends on the issue you've specified.

Please follow the issue to get the latest updates on it.

Thank you.

0

Please sign in to leave a comment.