Resharper++ with CMake (again)

This post seems to more-or-less cover the same problem I'm having, but with Resharper Ultimate 2018.3.3.  I have recently moved from coding in .Net to C++, but Resharper++ is proving to be a huge headache. 

Any time I have to make a change to one of the hundreds of CMakeLists.txt files in our large project (200 projects in the solution) and regenerate the make files, Resharper++ seems to have to re-index a large chunk of the project space - even when the CMakeFiles.txt edit doesn't touch a single source code file.  Typically, I'm working in VS.  I'll edit the file and rebuild, which causes some of the projects to be unloaded and reloaded to accomodate the change.  Resharper then starts updating source files.

Since a nominal rescan of the project already takes more than half a day, I find myself in a position where Resharper++ is never actually available for use - it's always "thinking" and slowing down Visual Studio to the point of frustration.  



1 comment
Comment actions Permalink


Sorry about that, we're aware of the issue but haven't come up with a solution yet. You can vote for to receive an update if the situation changes. The problem is that reloading a project looks like the project gets deleted and then added back to the solution, so we'll somehow have to keep "dead" files in the cache to solve this.

In the meantime have you tried using the built-in Visual Studio CMake support with your solution (File | Open | CMake)? Usually this is a preferred way of working with CMake solutions nowadays, unless it doesn't work for some reason.

Another option is to exclude some parts of your codebase that you are not working on from the indexing process alltogether (


Please sign in to leave a comment.