Why is my long line getting chopped when 'Wrap long lines' is disabled?

This is an example of a line that gets chopped/wrapped at the first comma when I do a code cleanup. I want it to stay as is without chopping.

_.each(this.userCoordinationNonDefaultTypes, (userCoordinationNonDefaultType: someNameSpace.IClaimUserCoordinationType, i: number) => {

becomes

_.each(this.userCoordinationNonDefaultTypes,

(userCoordinationNonDefaultType: someNameSpace.IClaimUserCoordinationType, i: number) => {

I have the ''Wrap long lines' disabled. I went through the settings in that section and changed some of them which I thought might help but they had no effect.

Anyone knows which setting affects this line?

3 comments

Hello Abdu!

 

 

Could you please specify what is set to corresponding options:

ReSharper | Options | Code Editing | C# | Formatting Style | Line Breaks and Wrapping | Hard wrap at

ReSharper | Options | Code Editing | C# | Formatting Style | Line Breaks and Wrapping | Arrangement of invocations | Wrap invocation arguments.

Thanks in advance.

0

Hello Abdu!

 

Could you please provide your dotsettings files (https://www.jetbrains.com/help/resharper/Sharing_Configuration_Options.html#managing) and extended code sample so we could reproduce the problem on our side. You can do it privately via 'Submit a request' form.

Thank you.

0

Please sign in to leave a comment.