How to prevent Resharper from learning settings/preferences?

Completed
When I've opened a project for the first time in Visual Studio there's a Resharper alert in the top-right of the window which says something like "Resharper will learn your preferences from other files in this project. If you want to disable this feature click here."
 
Unfortunately I didn't click this when I saw it and the alert doesn't appear thereafter.
 
I've looked through the settings but I can't see an option to turn off this feature. Can anyone point me in the right direction?
 
[My specific reason for wanting to disable this feature is that Resharper keeps adding two lines between functions, properties, using statements and the namespace, etc., which we used to use as our in-house style but have since moved away from. But despite stating this single-line preference in the Resharper settings, Resharper continues to replace a single empty line between functions, etc., with two empty lines. This doesn't happen for my colleagues amongst whom we share the settings file; it only happens for me.]
3 comments

Hello Andrew!

 

ReSharper doesn't support auto-detecting formatting settings, this option is implemented only for naming style.

Could you please provide the following info:

1. sample code that is formatted the weird way;

2. command you use for formatting;

3. your settings files (here's described how to export them - https://www.jetbrains.com/help/resharper/Sharing_Configuration_Options.html#managing).

I suppose it's preferable to share this info using "Submit a request" form.

Thanks in advance.

0

Hi Angelina,

I realised that it's naming conventions that it's learning. And as for the other settings, such as two lines between functions, this was a hangover from an old settings file that I had de-selected but it appears that Resharper was still using those settings. A few days ago I completely reset all my Resharper settings then copied a colleague's settings file and selected that, then chose the "Copy to... " option and overwrote my local settings. This seems to have worked.

0

Hello Andrew!

 

Thank you for lettings us know.

Please feel free to contact us in case of any questions or problems.

0

Please sign in to leave a comment.