Inconsistent naming triggered for no apparent reason.
Our team uses the naming rule UpperCamelCase_UnderscorTolerant for our C# project.
I have the following method:
private string FrameNumberToString(int frameNumber)
{
<stuff>
}
For some reason, I get a warning that the name is inconsistent and it suggest I rename the method to NumberToString. This happens with variables to; any mention of "Frame" is met with extreme prejudice.
It is possible that because we share the same dotsettings with the team that somebody has introduced some interesting setting - perhaps even myself by mistake - but I can't even think why there should be a prejudice against Frames.
Even FameNumberToString is acceptable for some reason while FrameNumberToString is not.
As there is a lot of mentions of Frames in this project, this is getting very annoying.
Please sign in to leave a comment.
Hello Tim!
Thank you for contacting us.
Please try disabling ReSharper | Options | Code Editing | C# | Naming Style | Use auto-detected rules option.
Thank you.
Thanks. I found the problem not long after posting. I apologize for not getting around to mentioning that and saving you time. I deleted the pattern (and other weird random patterns) from the configuration file and that worked.