Our team uses the naming rule UpperCamelCase_UnderscorTolerant for our C# project.
I have the following method:
private string FrameNumberToString(int frameNumber)
For some reason, I get a warning that the name is inconsistent and it suggest I rename the method to NumberToString. This happens with variables to; any mention of "Frame" is met with extreme prejudice.
It is possible that because we share the same dotsettings with the team that somebody has introduced some interesting setting - perhaps even myself by mistake - but I can't even think why there should be a prejudice against Frames.
Even FameNumberToString is acceptable for some reason while FrameNumberToString is not.
As there is a lot of mentions of Frames in this project, this is getting very annoying.