Why doesn't ReSharper like the word "Producer"?

I upgraded from 18.2 to 18.3 today (VS2015). I have a lot of code with properties and classes that start with the word Producer. They're all flagged with the warning that they don't match rule 'Properties' or 'Types and namespaces' and that the proper name is just without the word "Producer".


e.g. ProducerName → Name 'ProducerName' does not match rule 'Properties'. Suggested name is 'Name'.


When I select the change rule options to see what's causing it I only see the one rule UpperCamelCase which all of my properties and classes match. Nothing else is getting flagged like this, just things that start with the word Producer.

Comment actions Permalink

Hello Brandon!


Thank you for contacting us.

Please check if ReSharper | Options | Code Editing | C# | Naming Style | Use auto-detected rules option in enabled and turn it off.

Thank you.

Comment actions Permalink

Hi Angelina,

Thanks, that worked.

FYI, the only difference between the default settings and the auto-detected rules is "Static readonly fields (not private)" which is set to "ProducerUpperCamelCase (not inspected)".

When I tried to edit this rule to remove the Producer prefix or set the inspected flag it wouldn't save.


Please sign in to leave a comment.