VS2019-Preview warning for 2018.3 dependency of 'synchronous auto-load'

Answered

Current (16.0.0 Preview 1.1) VS2019 Preview raises a warning about extension compatibility in the UI. Running devenv /log, I see the following in C:\Users\***\AppData\Roaming\Microsoft\VisualStudio\16.0_a5ab8a6a\ActivityLog.xml:

557 Warning Extension 'JetBrains ReSharper Ultimate 2018.3 EAP 9' uses the 'synchronous auto-load' feature of Visual Studio. This feature will no longer be supported in a future Visual Studio 2019 update, at which point this extension will not work. Please contact the extension vendor to get an update. (UI Context: {adfc4e64-0397-11d1-9f4e-00a0c911004f} Package Guid: {0c6e6407-13fc-4878-869a-c8b4016c57fe})

Regards,

ShaiB

 

3 comments

Updated to the latest version and added it to the instance of 2019 Preview I have installed and got this as well. Just wanted to make sure that the devs were aware of this. https://blogs.msdn.microsoft.com/visualstudio/2018/05/16/improving-the-responsiveness-of-critical-scenarios-by-updating-auto-load-behavior-for-extensions/

0

Hello everyone!

 

We are aware of this problem and we are working on it, please refer to the following issue - https://youtrack.jetbrains.com/issue/RSRP-472937.

Thank you.

1

Please sign in to leave a comment.