Cannot launch debugger. HResult: 89710016

Completed

I get the following error when I attempt to debug tests in my project.  I can restart Visual Studio and it will work again for about 10 minutes and then quit.  I have also tried debugging the tests in x86 mode.

I'm running latest versions of Resharper and Visual Studio 2017.

 

 

 

21 comments

Hello!

 

Thank you for contacting us.

Could you please specify if you experience the same problem when using VS test runner? What test framework is used in your project?

Could you please also run Visual Studio with the following command line: 'devenv /ReSharper.LogFile C:\resharper_log.txt /ReSharper.LogLevel Verbose', reproduce the issue and send us a corresponding 'resharper_log.txt' file. It can be done privately via 'Submit a request' form.

Thank you.

0

I submitted a request this morning.

0

I'm having the same issue on VS 2019 Preview 1.1 when I try to run a unit test in debug mode. I'm using Microsoft.VisualStudio.TestTools.UnitTesting library. 

2

Alex, do you use VPN?  One of the things they told me to try was disconnecting from it when you have the problem.  Unfortunately I haven't been able to try it yet as I was pulled from that project to work on another one.

0

Thanks, @Kjackson. No, no VPN here. It seems this is an issue with EAP on any version of VS right now. My licensed copy of R# works fine on VS 2017 for unit tests though, so this is a new bug they've introduced.

0

Hello Alex!

 

Thank you for the feedback.

Could you please specify what EAP build you are using and hat kind of test project you are working in: .NET Core, .NET Framework?

It would be unbelievably kind if you could provide us some sample solution demonstrating the issue.

Thank you.

0

R# was 2018.3 EAP 7 and just updated to 2018.3 EAP 8 and the issue persists. This is with .NET Framework. I'll try to make the sample solution to send you as time allows.

I've submitted the bugs privately via the Exception Browser. Here are the details of the errors:

SubProducts.0 = JetBrains ReSharper 2018.3 EAP 8 Build 2018.3.20181206.92133-eap08

Failed to start debugger session "Unit-Testing debug session". HResult: 89710016. The operation completed successfully

--- EXCEPTION #1/2 [Win32Exception]
Message = “The operation completed successfully”
ExceptionPath = Root.InnerException
NativeErrorCode = 0
ClassName = System.ComponentModel.Win32Exception
HResult = E_FAIL=EFail=80004005

--- Outer ---

--- EXCEPTION #2/2 [LoggerException]
Message = “Failed to start debugger session "Unit-Testing debug session". HResult: 89710016.  The operation completed successfully”
ExceptionPath = Root
ClassName = JetBrains.Util.LoggerException
Data.ManagedThreadName = <NULL>
Data.SccRevisionShell = “<there are no packages matching the criteria>”
Data.HostProductInfo = “JetBrains ReSharper Ultimate 2018.3 EAP 8 Build 183.0.20181206.90152-eap08”
Data.SubProducts.#0 = “JetBrains ReSharper 2018.3 EAP 8 Build 2018.3.20181206.92133-eap08”
Data.SccRevisionEnv = “
  Platform\Core\Shell:
      git::refs/heads/183-eap8::c5cc567326af97f6391f42e70c910ce5cc1d99c0
 
 
  Platform\VisualStudio:
      git::refs/heads/183-eap8::dedbd34c66323dea9f538bb93f3ba6002375dd25

Data.VsVersion = 16.0.28408.50
Data.VsPreview = True
InnerException = “Exception #1 at Root.InnerException”
HResult = COR_E_APPLICATION=80131600
StackTraceString = “
  at JetBrains.PsiFeatures.VisualStudio.Core.UnitTesting.VsDebuggerFacade.<>c__DisplayClass16_0.<RunDebuggerSession>b__0(Lifetime lt)
     at JetBrains.DataFlow.Lifetimes.Using(Action`1 λ)
     at JetBrains.PsiFeatures.VisualStudio.Core.UnitTesting.VsDebuggerFacade.RunDebuggerSession(Lifetime lifetime, String name, ISolution solution, DebugSessionDescriptor debugSessionDescriptor, Action onFinish)
     at JetBrains.ReSharper.UnitTestFramework.DebugHostController.StartProcess(ProcessStartInfo startInfo, IUnitTestRun run, ILogger logger)
     at JetBrains.ReSharper.UnitTestFramework.Launch.UnitTestLaunch.HostControllerWithLogging.StartProcess(ProcessStartInfo startInfo, IUnitTestRun run, ILogger logger)
     at JetBrains.ReSharper.UnitTesting.MSTest.Provider.Execution.MsTestRunStrategyBase.RunProcess.Run(ProcessStartInfo startInfo, ILogger logger)
     at JetBrains.ReSharper.UnitTesting.MSTest.Provider.Execution.MsTestExecutionProtocol.VsTestExecutionEngineInvoker.Start(VsTestRuntimeEnvironment env, ILogger logger, IDictionary`2 environmentVariables)
     at JetBrains.ReSharper.UnitTesting.MSTest.Provider.Execution.MsTestExecutionProtocol.StartRunner()
     at Appccelerate.StateMachine.Machine.ActionHolders.ArgumentLessActionHolder.Execute(Object argument)
     at Appccelerate.StateMachine.Machine.States.State`2.ExecuteEntryAction(IActionHolder actionHolder, ITransitionContext`2 context)
     at Appccelerate.StateMachine.Machine.States.State`2.ExecuteEntryActions(ITransitionContext`2 context)
     at Appccelerate.StateMachine.Machine.States.State`2.Entry(ITransitionContext`2 context)
     at Appccelerate.StateMachine.Machine.States.State`2.EnterShallow(ITransitionContext`2 context)
     at Appccelerate.StateMachine.Machine.States.State`2.EnterHistoryNone(ITransitionContext`2 context)
     at Appccelerate.StateMachine.Machine.States.State`2.EnterByHistory(ITransitionContext`2 context)
     at Appccelerate.StateMachine.Machine.Transitions.Transition`2.Fire(ITransitionContext`2 context)
     at Appccelerate.StateMachine.Machine.States.State`2.Fire(ITransitionContext`2 context)
     at Appccelerate.StateMachine.Machine.StateMachine`2.Fire(TEvent eventId, Object eventArgument)
     at Appccelerate.StateMachine.ActiveStateMachine`2.ProcessEventQueue(CancellationToken cancellationToken)
     at Appccelerate.StateMachine.ActiveStateMachine`2.<Start>b__32_0()
     at System.Threading.Tasks.Task.InnerInvoke()
     at System.Threading.Tasks.Task.Execute()
     at System.Threading.Tasks.Task.ExecutionContextCallback(Object obj)
     at System.Threading.ExecutionContext.RunInternal(ExecutionContext executionContext, ContextCallback callback, Object state, Boolean preserveSyncCtx)
     at System.Threading.ExecutionContext.Run(ExecutionContext executionContext, ContextCallback callback, Object state, Boolean preserveSyncCtx)
     at System.Threading.Tasks.Task.ExecuteWithThreadLocal(Task& currentTaskSlot)
     at System.Threading.Tasks.Task.ExecuteEntry(Boolean bPreventDoubleExecution)
     at System.Threading.Tasks.ThreadPoolTaskScheduler.LongRunningThreadWork(Object obj)
     at System.Threading.ThreadHelper.ThreadStart_Context(Object state)
     at System.Threading.ExecutionContext.RunInternal(ExecutionContext executionContext, ContextCallback callback, Object state, Boolean preserveSyncCtx)
     at System.Threading.ExecutionContext.Run(ExecutionContext executionContext, ContextCallback callback, Object state, Boolean preserveSyncCtx)
     at System.Threading.ExecutionContext.Run(ExecutionContext executionContext, ContextCallback callback, Object state)
     at System.Threading.ThreadHelper.ThreadStart(Object obj)

0

Angelina Elycheva, I've submitted a private request with a sample solution attached that produces the error. 

0

Same issue here.  Error box appears when trying to start a debugging session for a unit test using MSTest.  This is on a brand new computer.

Windows 10 Enterprise x64
Version 10.0.16299 build 16299

Visual Studio Professional 2019 RC
Version 16.0.0 RC.3

JetBrains ReSharper Ultimate 2018.3.4 Build 183.0.20190304.43214
dotCover 2018.3.20190304.45822
dotTrace 2018.3.20190304.45704
ReSharper C++ 2018.3.20190304.45348
ReSharper 2018.3.20190304.45354
dotMemory 2018.3.20190304.45658

2

I'm having this problem now too on VS 2019 GA with the resharper v2018.3.1. This is happening on both of my machines.

VS 2017 is working fine.

1

Same for me. Windows 7, VS2019 GA, Resharper 2018.3.4

0

Same here. Windows 10, VS2019, Resharper 2018.3.4. Never had this problem before.

1

Hello everyone!

 

Could you please try installing ReSharper 2019.1 EAP 4 and check if the problem is still reproduced - https://www.jetbrains.com/resharper/eap/

Thank you.

0

The issue is gone for me with ReSharper 2019.1 EAP 4. Thanks, Angelina Elycheva.

1

Yes, 2019.1 EAP4 fixed the problem.

1

Having the same issue with 2010. Installed EAP 4, did not work:

 

0

EAP 4 and 2019 GR and it's working again

0

Hello Schase!

 

Could you please run Visual Studio with the following command line: 'devenv /ReSharper.LogFile C:\resharper_log.txt /ReSharper.LogLevel Verbose', reproduce the issue and send us a corresponding 'resharper_log.txt' file.

Also some sample solution demonstrating the problem will be appreciated.

You can share this information privately via 'Submit a request' form.

Thank you.

0

I'm getting the following from the errors that are returning on the test window:

 

2019.04.13 16:00:46.185 ERROR Transition failed: Transition from state <Disconnected> on event <local::Connect>. Executable file to start couldn't be found on path 'C:\Program Files (x86)\Microsoft Visual Studio\2019\Enterprise\Common7\IDE\CommonExtensions\Microsoft\TestWindow\vstest.executionengine.x86.exe' The system cannot find the file specified

 

And sure enough if I look in that folder there's no such file. The only executable I have in that folder is:

vstest.console.exe

Oddly this problem comes and goes. I had this working, now it's failing again (after a VS 2019 update).

 

+++ Rick ---

 

0

Hello Rick!

 

Thank you for the feedback.

Please try installing the latest R# EAP build https://www.jetbrains.com/resharper/eap/ and check the same issue once again.

Thank you.

0

Please sign in to leave a comment.