Resharped menu greyed out in Visual Studio

In Visual Studio 2017, Resharper menu for Navigate and and Refactor are grayed out and I cannot use them. Need help with this

14 comments
Comment actions Permalink

Hello!

 

Thank you for contacting us.

Could you please provide some screenshot illustrating the issue?

Thank you.

0
Comment actions Permalink

Thank you for the screenshot.

Though I should ask you for another one showing some code context for which the specified menu items are greyed out. It will be very helpful.

Could you please also check if the problem is reproduced in newly created console project for main method?

Thank you.

0
Comment actions Permalink

It works for a newly created console project

 

0
Comment actions Permalink

Thank you for the reply.

Please try:

1. clearing caches as described in the following help article - https://resharper-support.jetbrains.com/hc/en-us/articles/206546989-ReSharper-stopped-working-for-a-single-specific-solution

2. clearing .vs folder inside solution folder.

Thank you.

0
Comment actions Permalink

I have the exact same problem as the original poster, only the problem persists for all solutions, even new console apps.

I have tried rebooting, uninstalling R# and reinstalling (as admin), nothing works.

Thanks.

1
Comment actions Permalink

Hello Johnrs!

 

Could you please specify what ReSharper version you are using?

Also some screenshot demonstrating the problem will be helpful.

Thanks in advance.

0
Comment actions Permalink

Hello Angelina,

Thanks for your reply. I have solved the issue by running visual studio as an administrator.

0
Comment actions Permalink

I have this issue now. My context is Windows 10 Enterprise Version 10.0.18362 Build 18362, Microsoft Visual Studio Enterprise 2019 Version 16.3.2, with Visual Studio JetBrains ReSharper Ultimate 2019.2.2 Build 192.0.20190828.114715 (ReSharper C++ 2019.2.20190828.152258, ReSharper 2019.2.20190828.152259).

 

 

Have tried the following without success:

- Deleting the contents under %AppData%\Local\JetBrains\Transient.

- Deleting the .vs folder for my solution.

- Running Visual Studio as administrator.

 

Any help would be greatly appreciated, thanks.

0
Comment actions Permalink

Hello Tommy,

 

Could you please check if the issue is reproduced in a newly created solution or is it reproduced in some specific solution/project/file only?

Thank you

0
Comment actions Permalink

Hello Tommy,

I just had this myself today, and was here looking for a solution when I solved it.

I had just renamed the solution, and every project within as part of a refactor, and had edited the properties of each Project to reflect my desired new namespace names.

 

I also had a connected service, which I had just reconfigured, in the namespace.

 

The problem was, I thought my next step would be Ctrl-R-R on the namespace itself, in the .cs file, but Refactor was disabled.

 

Manually editing the namespace in the .CS file re-enabled refactoring in R#.

 

HTH.

 

Jeff Woods

Reading, PA

 

0
Comment actions Permalink

fwiw we ran in to this problem today. It turned out the developer had opened the projects as folders rather than via the solution file.

0
Comment actions Permalink

I have the same issue, the refactor option is grayed out

 

0
Comment actions Permalink

Hello,

Please note that the availability of the "Refactor" option depends on the location of the cursor. Perhaps the cursor is in the incorrect place, so Refactoring doesn't work. Does the option work in other cases, e.g. for class Program, method Main?
Does the problem affect all files in the solution?
Also, please provide a screenshot of the whole VS window including the vertical scrollbar where Refactor menu item is disabled.

0

Please sign in to leave a comment.