Intellisense constantly stops working

I don't know why, but in the past few days all of a sudden Resharper's intellisense stops working. All. The. Time. Constantly. When this happens, if I switch the resharper setting to use Visual Studio's intellisense instead of Resharper's own version, then intellisense starts working again. Switch it back to resharper: stops working. The only fix is to close and reopen my solution and then Resharper's intellisense starts working again. This is happening all the time throughout the day. I'd say easily a dozen times. I haven't changed any settings in VS or Resharper and I'm just working in the same project. To be more specific, what fails is after you type a . character you no longer see anything appear in the suggestion box. Nor do you see anything when you just start typing. I wish I could give a repro case but I can't. I sort of think it happens if I alt-tab after typing a . character on a variable to look at something and then come back but that could just be coincidence.

Edit: I'm using version 2017.3.3 built on 2018-03-02. Also I've tried clearing my cache a bunch of times.

5 comments

Hello Jeff!

 

Thank you for contacting us.

Could you please run Visual Studio with the following command line: 'devenv /ReSharper.LogFile C:\resharper_log.txt /ReSharper.LogLevel Verbose', reproduce the issue and send us a corresponding 'resharper_log.txt' file. You can do it privately via 'Submit a request' form.

Thank you.

0

I tried doing this over the weekend, but the log file never appears. When does the log file get created and written to? I had VS open for a few hours and shut it down normally but never saw a file in c:\

0

Hello Jeff!

 

Thank you for the reply.

Possibly you have no rights on writing new file in root C:. Please try changing the log file folder to any suitable one and try again.

Thank you.

0

I am also having this problem. I can fix it by suspending resharper then starting it again. After about 10 minutes it breaks again. Also the UI goes "not responding" and the visual studio process goes to 100% cpu usage for about 10 seconds every 5-10 minutes as well.

When this occurs I see this down the bottom right hand corner. After about 30 seconds it disappears without displaying intellisense.

https://i.imgur.com/vI03cPM.png

This is an extremely frustrating problem. It was recently fixed in a prior update and now it is back!

0

When my Resharper's Intellisense stops working I type the following command in the VS Command Window => "ReSharper_ToggleSuspended" to switch it off and "ReSharper_ToggleSuspended"  to switch it back on again and it works.

0

Please sign in to leave a comment.