Can't turn off Smart Indent?

Completed

I'm using Resharper 2017.3.1 in VS 2017 C++

In a header file, when I press enter on a line,Visual Studio will auto-tab to align the next line with the previous one (when smart indent is on). This is the behaviour I want.

When resharper is active, and I press enter, it auto-tabs against the class instead of the previous line. This usually means inserting 1 tab, even when the line above was 3 tabs deep. This behaviour is what I don't want.

Turning off 'Smart Indent on Enter' in the Resharper options has no effect at all. Pressing Enter does the same thing whether the option is on or off.

I've closed/reopened files, restarted VS, restarted the machine. It seems like Resharper overrides the VS indentation on Enter regardless of the settings. The only thing that fixes it is to disable the resharper extension in VS.

Any ideas please?

0
4 comments

Hello Alastair!

 

Thank you for the feedback.

Could you please sheck if ReSharper | Options | Code Editing | C++ | Formatting Options | Tabs and Indents | Use indent style and size from Visual Studio is turned on?

Thank you.

0

Yes it is turned on. I've just tried it on and off and it gives same behaviour for both.

0

Hello Alastair!

 

It turns out to be an issue, I've filed it here - https://youtrack.jetbrains.com/issue/RSCPP-21011

Please feel free to comment or vote for it.

Thank you.

0
Avatar
Permanently deleted user

Hello Alastair,

We'll fix configurability of C++ typing assist. Please try setting "Auto-insert closing brace" to "None" to disable it for now.

Please also note there's a dedicated forum for R++: https://resharper-support.jetbrains.com/hc/en-us/community/topics/200366089-ReSharper-C-.

Thanks!

0

Please sign in to leave a comment.