Peek Definition not working after 2016.2

Answered

I upgraded to 2016.2 and Peek Definition stopped working. All the following do nothing:

  • Right-click > Peek Definition
  • Alt+F12 (this is the shortcut for Edit.PeekDefinition)
  • Ctrl+Shift+Q (this is the shortcut for ReSharper_PeekDefinition)

When I suspend Resharper through Tools > Options > Reshaper Ultimate > Suspend Now, Peek Definition functionality begins working again. I've tried searching, but haven't had luck with finding a resolution.

Is there a way to restore that functionality without having Resharper suspended? Thank you.

21 comments
Comment actions Permalink
Official comment

Hello Logan, Collin,

Thanks for the log files. 

It seems as if the issue is VS2013 specific since Peek Definition works in VS2015. I filed a new request to YouTrack https://youtrack.jetbrains.com/issue/RSRP-460542, so feel free to follow it.

My apologies for the inconvenience.  

Comment actions Permalink

Not working in VS 2015 either.

1
Comment actions Permalink

Hello Logan

Does it happen in such particular solution only or affect all solutions you have even a newly created one?

Thanks!  

0
Comment actions Permalink

The problem happens in all solutions, even newly created ones.

0
Comment actions Permalink

Please could you run Visual Studio with the following command line: 'devenv /ReSharper.LogFile C:\log\resharper_log.txt /ReSharper.LogLevel Verbose'. After that reproduce the issue, submit a new support ticket ("Submit a request" above) and attach the corresponding 'resharper_log.txt' file to the ticket.

Thanks! 

0
Comment actions Permalink

I am experience the same issue! I've been looking to see what caused this and I just saw this post from a google search. I reset Visual Studio back to complete default settings as well as ReSharper and it worked for a little while, but it stopped working again. The shortcut nor the menu option work.

0
Comment actions Permalink

Should have mentioned that I'm on:

JetBrains ReSharper Ultimate 2016.2.2 Build 106.0.20160913.91321
ReSharper 2016.2.20160913.92608

I see that it was supposedly fixed in 2016.2.1 but it's not working for me.

0
Comment actions Permalink

I have R# 2016.2.2 and VS2015 and Peek Definition doesn't work anymore for rme too!

0
Comment actions Permalink

Hello Ron, Laurent, 

Does the issue happen:

- for any solution?  

- for any way to call it: Right-click > Peek Definition, Alt+F12 (this is the shortcut for Edit.PeekDefinition, Ctrl+Shift+Q (this is the shortcut for ReSharper_PeekDefinition)? 

 

What VS2015 build version do you use? 

Thanks! 

0
Comment actions Permalink

Hi Alexander,

Right-click > Peek Definition : Is working

Alt+F12 (this is the shortcut for Edit.PeekDefinition, Not working, normal I use R# 2.x or IntelliJ IDEA keyboard Shortcuts

Ctrl+Shift+Q (this is the shortcut for ReSharper_PeekDefinition) Not working, even after re-mapping to this shortcut

I tried with a second existing solution and had exactly the same issue!

I created a third C# console application solution from scratch and had exactly the same way of behaving as described before!!

I changed Keyboard Shorcuts to Visual Studio then back to R# 2.x or IntelliJ IDEA, same!

Cheers
Laurent

 

 

0
Comment actions Permalink

Hello Laurent,

It is expected behavior that "ReSharper_PeekDefinition" action does not work in VS2015. That was an experimental feature in VS2013 to replace Visual Studio content in "Peek Definition" window with the code decompiled by dotPeek in case you call such action for some external type.

So, in Visual Studio 2015 you may call Peek Definition only via "Right-click > Peek Definition" and via a shortcut, mapped to Edit.PeekDefinition action.

Thanks! 

0
Comment actions Permalink

Hello Alexander,

 

Finally after your clarification and several reset (VS, R#) I have it working with Ctrl+Shift+Q, which is the setting I was using in the past!

 

Thanks for your help

Laurent

0
Comment actions Permalink

Awesome! You are welcome! 

0
Comment actions Permalink

Alexander,

This fixed it for the keyboard shortcuts, however the Ctrl+Shift+Click method is still broken. It is described here: https://www.jetbrains.com/help/resharper/2016.2/Navigation_and_Search__Peek_Definition.html

I have to assume it is still attempting to execute ReSharper_PeekDefinition which is why its not working.

0
Comment actions Permalink

I have the same problem... ALL methods of invoking Peek Definition do nothing FOR LIBRARY TYPES --- if the class is in a solution project, then the popup will open. Suspending R# makes it work as expected. E.G.:


public static readonly DependencyProperty ColumnGeneratorOwnerProperty
= DependencyProperty.RegisterAttached(
"ColumnGeneratorOwner",
typeof(HeadDataGrid),
typeof(HeadDataGrid));

 

Right-click on RegisterAttached, and select Peek Definition, and nothing happens.

 

Happens in all projects and solutions. I am on R# Ultimate 2018.1 and VS Enterprise 2017 15.6.6

0
Comment actions Permalink

Peek doesn't work for me either, but only for non user defined types (i.e. Framework library types, or nuget package types), I have Visual Studio Professional 2017 version 15.7.4 and ReSharper Ultimate 2018.1.2.

It affects all projects and solutions.

0
Comment actions Permalink

Hello Matthew and Steven!

 

 

The problem you're experiencing is related to the following known issue - https://youtrack.jetbrains.com/issue/RSRP-466583.

You are welcome to comment or vote for it.

Please accept our apologies for inconvenience.

Thank you.

0
Comment actions Permalink

Thanks for the reply Angelina. 

The issue you've linked to is about .Net core, but none of my projects use .Net core, so I'd guess it's probably a different issue.

0
Comment actions Permalink

Hello Matthew!

 

Thank you for the reply.

Could you please specify what kind of projects you are working on? Is there any chance you could provide some solution so we could reproduce the problem?

Thank you.

0
Comment actions Permalink

... In case it is helpful to some followers, I also reported a bug about Peek Definition not working, but there was a simple fix for that problem:

https://youtrack.jetbrains.com/issue/RSRP-469408

"try to go ReSharper Settings | Tools | External Sources  and select Navigation to Sources ?"

0
Comment actions Permalink

@Steven Coco, I have this option from the beginning - and that does not help. Assemblies are decompiled correctly, however those are just reference assemblies - really containing nothing.

I was also trying to set up VS to load symbols to predefined folder and set its path to ReSharper, but still no luck. (Not even sure whether this is ReSharper issue, VS without ReSharper acts the same. There should be some mapping realizing what you want to see instead of reference assembly)

0

Please sign in to leave a comment.