Tab key behaviour overridden


 Hi there,

previously on typing text, the intelli sense from VStudio shows possible words, and on typing TAB, it selected that chosen word out of the drop down list. With Resharper (2016.2), it moves instaead the cursor to some next text block.

This is a very anoying feature. Unfortunately, I need the TeamCity plug in, so that I cannot suspend all of Reshaper. Every other moduls is disabled but TeamCity. How can I deactivate this TAB - override function from Resharper?


Keyboard shortcuts are set to Visual Studio. Only Active Product is TeamCity.

Kind regards


Try turning off structural navigation (Options -> Editor -> Editor Behavior).


Hello Lionel

Please could you be more specific about how you disabled other JB tools but TeamCity? Unfortunately, I was not able to reproduce the same issue you described. 

Anyway, Richard is correct, you may disable Tab navigation here ReSharper | Options | Environment | Editor | Editor Behavior | Structural Navigation | Untick the checkbox. If there is no such page, please enable ReSharper tool first.



Hi Richard, Hi Alexander,

Yeah, it's working now!

It took me some time to find that option. As mentioned, I have all produces deactivated. All but TeamCity.I first had to reactivate Resharper, to see and switch off the option.




Glad to hear it works now.

  1. How did you deactivate other products - via ReSharper | Options | Environment | Products & Features dialog or via other ways? 
  2. Which products have you installed - ReSharper, dotTrace, dotCover, etc? 
  3. Do you have VS plugins installed which extend or replace Visual Studio IntelliSense? 



1. Deactivate only over the Options | Environment | Products & Features

2. Installed are: dotCover, dotMemory, dotTrace, ReSharper, TeamCity Add-in

3. Not that I know. Productivity Power Tools gues could be the only. Not sure even if it does.

Btw.: I am using Visual Studio 2015 with Update 3, code is in C#



Thanks a lot for the reply. Looks as if I was able to reproduce similar behavior on my side. I filed ticket to YouTrack. 

My apologies for the inconvenience.



You are welcome.

No problem, I got quick help here, to solve the issue :)


Please sign in to leave a comment.