Disabling Resharper's rename in VS2015?

Answered

Last time I installed ReSharper, I was able to disable its rename in VS2015, but since then I had to reinstall Windows (and thus ReSharper), and now I can't get it back. Simply removing the keyboard shortcut Resharper.Resharper_Rename doesn't work, even though I'm certain this was what I did before. Was there a new version of ReSharper since then that forces itself to overwrite VS2015's inline rename? ReSharper's rename window is nothing compared to VS2015's well-designed inline rename, and is a feature I use very frequently. If there's no way to disable this now, I think I'll have to uninstall ReSharper entirely.

2 comments
Comment actions Permalink
Official comment

Hello Ryan,

Please try executing the following actions:

  1. Map Refactor.Rename for needed shortcut here Tools | Options | Environment | Keyboard;
  2. Open ReSharper | Options | Environment | Keyboard & Menus | Commands & Menus | Untick "Override VS refactorings" checkbox 

Thanks! 

Comment actions Permalink

Thanks! I forgot I needed to tell resharper explicitly not to override the options as well.

0

Please sign in to leave a comment.